IBM Support

"SQL30081N A communication error has been detected" errors when connecting Controller application server to DB2 database server

Troubleshooting


Problem

Administrator is trying to test communication between the Controller application server and the DB2 database server. For example, administrator opens a command prompt (D:\Program Files\IBM\SQLLIB\BIN) and runs a command similar to: db2 connect to user using . Administrator receives error message.

Symptom


SQL30081N A communication error has been detected. Communication protocol
being used: "TCP/IP". Communication API being used: "SOCKETS". Location
where the error was detected: "<IP_address>". Communication function detecting
the error: "connect". Protocol specific error code(s): "10060", "*", "*".
SQLSTATE=08001

Cause

DB2 server's firewall preventing communication from remote (application server) device.

Diagnosing The Problem

Try connecting to the DB2 server (from the application server) using the command "telnet".

  • If there is an error "Connecting To <servername>...Could not open connection to the host, on port 50000: Connect failed" then it is an indication that there is a firewall blocking communication.
  • Instead, if everything is working correctly, then the screen *should* change instantly to black.

Example:

Assuming that the DB2 server is running on the default TCP port (50000) then the command would be:

    telnet <DB2_servername> 50000

Resolving The Problem

Reconfigure the Windows firewall (running on the DB2 server) to allow communication in via the DB2 TCP port (default = 50000).

Steps:

1. Logon to the DB2 server as an administrator

2. Launch "Control Panel\System and Security\Windows Firewall"

3. Click "Advanced settings":


4. Click "New Rule"

5. Choose "Port":




6. Choose TCP and 50000 (if necessary modify this value to match your specific settings)

7. Choose "Allow the Connection":

8. Ensure that all locations are ticked:


9. Name the rule appropriately:


10. Click 'Finish' and test.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1;10.1;8.5.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21503305