Cannot install Rational Team Concert 3.0.x over Eclipse 3.6 because of plug-in dependencies

Technote (troubleshooting)


Problem(Abstract)

Attempts to install IBM Rational Team Concert on Eclipse 3.6 results in several different Eclipse errors due to plug-in dependencies.

Symptom

There are two ways to install Rational Team Concert features over an existing Eclipse installation:

  1. Use Installation Manager to install the offering
  2. Use the P2 install to get the features

Attempts to install Rational Team Concert with Installation Manager results in the following messages appearing during the pre-requisite check:

 Installing bundle "org.eclipse.xsd_2.5.0.v200906151043" into this existing Eclipse installation does not meet the version tolerance of "[2.6.0, 3.0.0]" for the existing bundle "org.eclipse.xsd.edit"

 Installing bundle "org.edlipse.emf.edit_2.5.0.v200906151043" into this existing Eclipse installation does not meet the version tolerance of "[2.6.0, 3.0.0]" for the existing bundle "org.eclipse.xsd.edit"

 Installing bundle "org.edlipse.emf.ecore_2.5.0.v200906151043" into this existing Eclipse installation does not meet the version tolerance of "[2.6.0, 3.0.0]" for the existing bundle "org.eclipse.jts.ws.jaxrs.ui"
 
  Offering cannot be installed into this existing Eclipse installation configuration because it has features that are not tolerated by the offering
  Feature "org.eclipse.equinox.p2.user.ui_2.0.1.r361_v20100903-897HFa-FX0z-z-ntoaavz0JPX628" in the existing Eclipse installation does not meet version tolerance "[1.1.2,2.0.0)" for feature "org.eclipse.pde" which is about to be installed



Attempts to install Rational Team Concert with P2 install results in the following messages appearing during the pre-requisite check:


Cannot complete the install because of a conflicting dependency.
  Software being installed: Rational Team Concert Client Feature 3.0.0.RTC-I20101112-1731 (com.ibm.team.rtc.client.feature.feature.group 3.0.0.RTC-I20101112-1731)
  Software currently installed: Eclipse IDE for C/C++ Developers 1.3.1.20100916-1202 (epp.package.cpp 1.3.1.20100916-1202)
  Only one of the following can be installed at once:
    Equinox  Provisioning Engine 2.0.0.v20100606 (org.eclipse.equinox.p2.engine 2.0.0.v20100606)
    Equinox  Provisioning Engine 1.0.102.R35x_v20091117 (org.eclipse.equinox.p2.engine 1.0.102.R35x_v20091117)

 Cannot complete the install because of a conflicting dependency.
  Software being installed: Rational Team Concert Client Feature 3.0.0.RTC-I20101112-1731 (com.ibm.team.rtc.client.feature.feature.group 3.0.0.RTC-I20101112-1731)
  Software currently installed: Eclipse XML Editors and Tools 3.2.2.v201008170029-7H7AFUQDxumQGOpBqffOY2f1qxDZ (org.eclipse.wst.xml_ui.feature.feature.group 3.2.2.v201008170029-7H7AFUQDxumQGOpBqffOY2f1qxDZ)
  Only one of the following can be installed at once:
    EMF Edit 2.5.0.v200906151043 (org.eclipse.emf.edit 2.5.0.v200906151043)
    EMF Edit 2.6.0.v20100914-1218 (org.eclipse.emf.edit 2.6.0.v20100914-1218)
 
 Cannot complete the install because of a conflicting dependency.
  Software being installed: Rational Team Concert Client Feature 3.0.0.RTC-I20101112-1731 (com.ibm.team.rtc.client.feature.feature.group 3.0.0.RTC-I20101112-1731)
  Software currently installed: SpringSource Tool Suite Runtime Error Analysis Support 2.6.0.201103161000-RELEASE (com.springsource.sts.runtimeerroranalysis.feature.group 2.6.0.201103161000-RELEASE)
  Only one of the following can be installed at once:
    XSD Model 2.5.0.v200906151043 (org.eclipse.xsd 2.5.0.v200906151043)
    XSD Model 2.6.0.v20100914-1218 (org.eclipse.xsd 2.6.0.v20100914-1218)

 Cannot complete the install because of a conflicting dependency.
  Software being installed: Rational Team Concert Client Feature 3.0.0.RTC-I20101112-1731 (com.ibm.team.rtc.client.feature.feature.group 3.0.0.RTC-I20101112-1731)
  Software currently installed: Eclipse IDE for Java EE Developers 1.3.1.20100916-1202 (epp.package.jee 1.3.1.20100916-1202)
  Only one of the following can be installed at once:
    XSD Model 2.5.0.v200906151043 (org.eclipse.xsd 2.5.0.v200906151043)
    XSD Model 2.6.0.v20100914-1218 (org.eclipse.xsd 2.6.0.v20100914-1218)

 Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse Plug-in Development Environment 3.6.2.r362_v20110203-7b7mFL2FET3dhHalh1iNZtL (org.eclipse.pde.feature.group 3.6.2.r362_v20110203-7b7mFL2FET3dhHalh1iNZtL)
  Software currently installed: Eclipse SDK 3.6.1.M20100909-0800 (org.eclipse.sdk.ide 3.6.1.M20100909-0800)
  Only one of the following can be installed at once:
    Eclipse Plug-in Development Environment 3.6.1.r361_v20100727-7b7mFL-FET3dhESDgE5_bkJ (org.eclipse.pde.feature.jar 3.6.1.r361_v20100727-7b7mFL-FET3dhESDgE5_bkJ)
    Eclipse Plug-in Development Environment 3.6.2.r362_v20110203-7b7mFL2FET3dhHalh1iNZtL (org.eclipse.pde.feature.jar 3.6.2.r362_v20110203-7b7mFL2FET3dhHalh1iNZtL)
    Eclipse Plug-in Development Environment 3.6.0.v20100525-7b7mFKtFEx2XmfZ4_B7NUJA (org.eclipse.pde.feature.jar 3.6.0.v20100525-7b7mFKtFEx2XmfZ4_B7NUJA)

Cause

When installing Rational Team Concert on Eclipse 3.6 some features from Eclipse must be present. While in some editions these features are already available, in others they must first be installed.

The following editions have been identified where additional features need to be installed:

  • Eclipse 3.6 Java EE
  • Eclipse 3.6 Java DE
  • Eclipse 3.6 C++
  • Eclipse 3.6 for RCP and RAP developers

As Installation Manager and the P2 install are going to try to install the missing features in the environment and as some plug-ins that are required/included by these features are already installed, the tolerance of these are not accepted by the incoming features, provoking that the validation fails.

Note: Installation Manager is not able to contact the Eclipse update sites, but the P2 install can, so if there is an Internet connection configured (and working), it is possible to solve the problem for the Java and CPP Editions with the P2 install by marking the checkbox "Contact all update sites during the install to find required software" while installing Rational Team Concert with the Install New Software option.

If an Internet connection is not available or you are using the Java EE or RCP Eclipse Editions, the features must be installed in the environment first.

Environment

Windows or Linux OS with an Eclipse 3.6 (Helios).

Resolving the problem

According to your Eclipse edition and your preferred way to install Rational Team Concert, apply one of the following steps to install the missing pieces:


INSTALLATION

  • Using the Installation Manager Install:
    1. Use the Launchpad to start Installation Manager (or start Installation Manager directly) to install the Rational Team Concert Eclipse Client
    2. Follow the usual steps to install over an Existing Eclipse environment

  • Using the P2 Install:
    1. Select Help > Install New Software
    2. Click Add
    3. Select the repository directory containing the Rational Team Concert update site.
    4. Mark the checkbox "Groups items by category"
    5. Select Rational Team Concert to install
    6. Accept the license
    7. Restart when prompted

Note: download the latest RTC packages from the RTC download site.


ECLIPSE EDITIONS

JEE and RCP Editions:
  1. Download the Eclipse Modeling Framework SDK Update (EMF) and extract to a location
  2. Select Help -> Install New Software then click "Add" and select the eclipse directory containing the EMF update site created in step 1. Optionally, for this scenario you can add the RTC update site repository at the same time and install all in one pass, but in order to make this optional step to work you need to select "--Only Local Sites--" in the "Work with:" combobox, then uncheck "Group items by category", select all the features and now check the "Group items by category". Continue with the install.
3. Select all to install. Restart eclipse when prompted.
4. Install RTC with IM or P2 (if it was not done in step 2). If the P2 install is going to be used make sure the "Group items by category" option is checked.

CPP Edition:
  1. Download Eclipse Plug-in Development Environment (PDE) and Eclipse Java Development Tools (JDT) and extract to a location
2. Select Help -> Install New Software then click "Add" and select the eclipse zips containing the PDE and JDT update sites that we got in step 1.
3. Select Eclipse PDE and Eclipse JDT to install, continue and restart eclipse when prompted.
4. Install RTC with IM or P2. If the P2 install is going to be used make sure the "Group items by category" option is checked.

Java Edition:
  1. Download the Eclipse Modeling Framework SDK Update (EMF) and Eclipse Plug-in Development Environment (PDE) and extract to a location
  2. Select Help -> Install New Software then click "Add" and select the eclipse directory containing the EMF update site and add the archive containing
the PDE update site that you got in step 1.
3. Select to install all the EMF features and the PDE feature from there and continue with the install. Restart eclipse when prompted.
4. Install RTC with IM or P2. If the P2 install is going to be used make sure the "Group items by category" option is checked.

Related information

jazz.net work item 156073
jazz.net work item 161576
jazz.net work item 159096
jazz.net work item 161881
jazz.net work item 161969

Rate this page:

(0 users)Average rating

Document information


More support for:

Rational Team Concert
Eclipse

Software version:

3.0, 3.0.1

Operating system(s):

Linux, Windows

Reference #:

1502374

Modified date:

2014-04-25

Translate my page

Machine Translation

Content navigation