WebSphere MQ PTF install fails with GIM24601E

Technote (troubleshooting)


Problem(Abstract)

When attempting to install PTFs to V6 of WMQ you receive one or more of the following messages:
GIM24601E ** LMOD ENTRY CMQXRCTL IS NEEDED FOR PROCESSING BUT IS NOT IN THE SMPCSI LIBRARY.
GIM24601E ** LMOD ENTRY CMQXSUPR IS NEEDED FOR PROCESSING BUT IS NOT IN THE SMPCSI LIBRARY.
GIM24601E ** LMOD ENTRY CMQXDCST IS NEEDED FOR PROCESSING BUT IS NOT IN THE SMPCSI LIBRARY.

Symptom

GIM24601E


Cause

Installing WebSphere MQ V6 in the same SMP/E (System Modification Program/Extended) CSI (Consolidated Software Inventory) as WMQ V5.3.1 Load modules CMQXRCTL, CMQXSUPR and CMQXDCST are left from the previous version of WMQ and need to be removed.

Diagnosing the problem

.

Resolving the problem

In order to resolve the problem the MOD entries which refer to CMQXRCTL, CMQXSUPR and CMQXDCST will need to be updated so that they no longer refer to these LMODs (load modules). The easiest way to do this is to run a SMP/E command UNLOAD MOD FORFMID(HMS6000), edit the output from the SMPPUNCH data set to remove references to CMQXRCTL, CMQXSUPR and CMQXDCST, and feed the edited output back into SMP/E as UCLIN

Historical Number

83166 7TD 000

Product Alias/Synonym

WMQ MQ

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere MQ
Install / Migration

Software version:

5.3.1, 6.0, 7.0, 7.0.1, 7.1

Operating system(s):

z/OS

Reference #:

1501235

Modified date:

2013-04-26

Translate my page

Machine Translation

Content navigation