IBM Support

Unable to run TI process: Cannot convert field number...

Troubleshooting


Problem

Turbo Integrator process fails when pulling data from a flat file.

Symptom

Error similar to following in the process error log:

"Company","Customer","Product","Week_End_Date","123_RealValue",Data Source line (1) Error: MetaData procedure line (0): Cannot convert field number 5, value "123_RealValue" to a real number.

When editing the process the following warning pops up:

Some problems occurred while getting the sample values for the following variables. The use of these variables in a formula will cause a "variable is undefined" error. To correct this you can either ignore the variable or fix the specific problem for each one of them.

123Qty : Cannot convert string to a number.

Cause

On Data Source tab, "Number of title records" was not set correctly so that the title records were pulling into the preview section.

Diagnosing The Problem

See process error log, located either in the data directory or in the logging directory specified in the tm1s.cfg file. Error log will look similar to: TM1ProcessError_<date/time stamp>_PROCESS NAME.log

Resolving The Problem

To resolve the problem, if there is one row of title records in the data source, then enter a 1 in the "Number of title records" on the Data Source tab of the process (if two rows, then enter a 2, etc.). Save the process, close it and then reopen to verify that the data preview looks correct and that the variable is pulling in correctly on the Variables tab. Run process to make sure that it is now running correctly.

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5;9.4;9.4 MR1;9.5.1;9.5.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21500586