IBM Support

Help file web page redirection in Maximo

Question & Answer


Question

Does Maximo use redirect of Help files like TSRM and CCMDB does?

Cause

Maximo uses Robohelp and not Eclipse based Help.

Answer

The answer to this question if this is also possible with Maximo like for example with CCMDB and TSRM , is "No" as Maximo works differently.

TSRM and CCMDB use Eclipse based Help and so can use a way to redirect to the correct help web page, Maximo does not have this option to do it this way as Maximo uses Robohelp instead of Eclipse.
The way to do this in TSRM/CCMDB is by simply creating a redirect.jsp to your Help plugin and that way redirect traffic to the appropriate Help Web page.

In Maximo, the Help file display works different as it does not use Eclipse, however Robohelp.

For Maximo you need to install the corresponding language package for the language you like the Help file to show in.

Maximo does not use redirect so it will want to bring up the page directly as it should for Maximo.
Under Maximohelp in the run time environment there are Help files for each installed language.

For further information on how to install the MAXIMOHELP application itself ,alternatively how to install or configure multiple or foreign Help file languages, please either see you Maximo SAG (System Administrator Guide) ,alternatively your Quick Start Guide for IBM Maximo Asset Management V7.1.x Multi-platform Multilingual.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.1;7.1.1;7.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSLKTY","label":"Maximo Asset Management for IT"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"","label":"Windows 2003 server"},{"code":"","label":"Windows 2008 server"}],"Version":"7.1;7.1.1;7.1.2;7.2;7.5","Edition":"All Editions","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSKTXT","label":"Tivoli Change and Configuration Management Database"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"},{"code":"PF027","label":"Solaris"},{"code":"PF010","label":"HP-UX"},{"code":"","label":"Windows 2000"},{"code":"","label":"Windows 2003 server"}],"Version":"7.2.1;7.5","Edition":"All Editions","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SS6HJK","label":"Tivoli Service Request Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"","label":"Windows 2003 server"},{"code":"","label":"Windows 2008 server"}],"Version":"7.2.1;7.5","Edition":"All Editions","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSWT9A","label":"IBM Control Desk"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21499897