Troubleshooting
Problem
While opening IBM Cognos Administration you can receive error "CNC-MON-0024 Monitor Service paging error: No suitable driver. When schedule the report you may also receive error "CNC-SDS-0256 Unable to connect to the database using jdbc:db2:cm."
Cause
Incorrect/Incomplete Notification database configuration done in IBM Cognos Configuration
Environment
Windows, Unix
Resolving The Problem
In this scenario the notification store details were not filled in properly on one of the application tier. The details about the notification database was just mentioned in IBM Cognos configuration where content manager was running.
In order to resolve this issue make sure that the Notification store
details in IBM Cognos Configuration on the system is specified on both the Application Tier as well as content manager. If you have multiple Application Tier then the notification store details should be specified on all the application Tier.
Restart Cognos service after making the changes in IBM Cognos Configuration.
If the issue still persist you may also try to Drop NC* tables.
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Document Information
Modified date:
15 June 2018
UID
swg21499572