IBM Support

Getting error CNC-MON-0024 Monitor Service paging error: No suitable driver

Troubleshooting


Problem

While opening IBM Cognos Administration you can receive error "CNC-MON-0024 Monitor Service paging error: No suitable driver. When schedule the report you may also receive error "CNC-SDS-0256 Unable to         connect to the database using jdbc:db2:cm."

Cause

Incorrect/Incomplete Notification database configuration done in IBM Cognos Configuration

Environment

Windows, Unix

Resolving The Problem

In this scenario the notification store details were not filled in properly on one of the application tier. The details about the notification database was just mentioned in IBM Cognos configuration where content manager was running.

In order to resolve this issue make sure that the Notification store     


details in IBM Cognos Configuration on the system is specified on both the Application Tier as well as content manager. If you have multiple Application Tier then the notification store details should be specified on all the application Tier.

Restart Cognos service after making the changes in IBM Cognos Configuration.

If the issue still persist you may also try to Drop NC* tables.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Connection","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2;10.1.1;10.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21499572