Troubleshooting
Problem
Robotic scripts playback on ITCAM T6-RRT agent but no applications or transactions data displays in the TEPS.
Symptom
No detailed data for T6-RRT agent playback of RPT/RFT scripts.
Cause
ITCAM environment configuration
Diagnosing The Problem
There are many possible configuration issues that prevent data from displaying in the TEPS. Here is a checklist of items that must be configured correctly for all T6-RRT data to show up properly in the TEPS:
- Verify the scripts are playing back successfully.
- Check for any errors in the trace-robotic logs found in the default Tivoli common logs directory:
Windows: %ALLUSERSPROFILE%\ibm\tivoli\common\BWM\logs\*
Unix/Linux: /var/ibm/tivoli/common/BWM/logs/
- There can only be one T3-AMC agent in the ITM environment. Verify with the following commands:
- Logon to HUB-TEMS and run the following command:
ITM_HOME/bin/tacmd login -s tems-server -u sysadmin -p sysadmin-password - On Windows, run the following command:
ITM_HOME\BIN\tacmd listSystems | find ":T3"
result : velocity:T3 T3 07.40.02.00 Y - On Unix/Linux, run the following command:
ITM_HOME/bin/tacmd listSystems | grep \:T3
result : velocity:T3 T3 07.40.02.00 Y
- Verify that the application support for the T3 and T6 agents is applied appropriately.
- Verify there are no space issues on the T3 and T6 agents.
- If the RPT Workbench is installed on the T6 agent do not run RPT while the T6 agent is started.
- Verify the T3 agent is at the highest version of any ITCAM agent
- Playback the script in the Rational environment (on the RPT/RFT workbench) to verify successful completion.
- Verify the AMC is pointing to the HUB TEMS
- The correct version of RPT/RFT must be installed with the correct ITCAM plugin on the RPT/RFT workbench.
- The correct extensions must be installed for RPT/RFT
Resolving The Problem
After verifying these items, if the data still does not display in the TEPS,
- Open a case for Tivoli support.
- Copy the list above into the case text along with the result of your findings for each of these items.
- Zip into a file the kincinfo -t (Windows) or cinfo -t (UNIX) data from the TEMS/TEPS/T6/T3 servers and the default Tivoli common logs directory (noted above) and upload to the case.
Related Information
[{"Product":{"code":"SS5MD2","label":"Tivoli Composite Application Manager for Transactions"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ITCAM TRANSACT RRT 5724S79RR v710","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.4","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
Product Synonym
ITCAM for Transactions;ITCAM for T;ITCAMfT
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Document Information
Modified date:
17 June 2018
UID
swg21499269