IBM Support

Unable to connect to Datapower using network services: WebGUI or ssh

Question & Answer


Question

Why can't I access the web management or ssh?

Cause

This can occur if you are using a custom certificate or authentication for the management services and any of the associated certificates are expired.  This can also occur after an upgrade as expired certificates are removed at upgrade time.

Answer

The first step is to verify that the network is functioning correctly using these commands:
show int
show int mode
show route

The commands will show if there is any network activity as well as the ethernet link speed.

Once the network is confirmed, the quickest way to recover the web management and ssh services is to delete and re-create them with the default settings using the serial console.

1. The following commands will reset the RBM's, ACL's, WebGUI and SSH services to the default settings:

If the ssh is working, you may omit any commands with the ssh.

config
web-mgmt
no ssl
exit
write mem
y
no web-mgmt
no ssh
rbm
reset
exit
acl web-mgmt
reset
exit
acl ssh
reset
exit
write mem  (key step to remove the current settings)
y
web-mgmt <ip to listen on or 0.0.0.0 for all> <port to use default is 9090>
ssh <ip to listen on or 0.0.0.0 for all> <port to use default is 22>
write mem
y

2. Now that the RBM's, ACL's, WebGUI and SSH services have been reset, the WebGUI and  SSH services can be reconfigured:

web-mgmt <ip to listen on or 0.0.0.0 for all> <port to use default is 9090>
ssh <ip to listen on or 0.0.0.0 for all> <port to use default is 22>
write mem
y

After completing the steps, test the service and confirm if you can access the DataPower Gateway.   Once you have access, you can work on configuring any custom certificates or authentication settings.

If this is a virtual appliance you would need to deploy a new instance and use a previous secure-backup (or previous export) to restore the configuration.

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Document Information

Modified date:
09 December 2022

UID

swg21498634