IBM Support

Unable to connect to Datapower using network services: WebGUI or ssh

Question/Answer


Question

Why can't I access the Web managment or ssh?

Cause

This can occur if you are using a custom certificate or authentication for the management services and any of the associated certificates are expired.  This can also occur after an upgrade as expired certificates are removed at upgrade time.

Answer

The first step is to verify that the network is functioning correctly using these commands:

show int

show int mode

show route

Those commands will show if there is any network activity as well as the ethernet link speed.

Once the network is confirmed, the quickest way to recover the web management and ssh services is to delete and recreate them with the default settings using the serial console.

The following commands will reset the RBM's, ACL's, WebGUI and SSH services to the default settings.

Note: If the ssh is working, you may omit any commands with the ssh.

config

web-mgmt

no ssl

exit

write mem

y

no web-mgmt

no ssh

rbm

reset

exit

acl web-mgmt

reset

exit

acl ssh

reset

exit

write mem  (key step to remove the current settings)

y

web-mgmt <ip to listen on or 0.0.0.0 for all> <port to use default is 9090>

ssh <ip to listen on or 0.0.0.0 for all> <port to use default is 22>

write mem

y

Once complete, test the service and confirm you can now access the appliance. Then you may work to configure any custom certificates or authentication settings desired.

If this does not resolve the issue Contact DataPower Support


Document information

More support for: IBM DataPower Gateways

Component: --

Software version: 7.6, 2018.4

Operating system(s): Firmware

Software edition: All Editions

Reference #: 1498634

Modified date: 24 July 2019