IBM Support

Unable to enter IBM Cognos Administration / System

Technote (troubleshooting)


Problem(Abstract)

User launches IBM Cognos Administration. User clicks (on the left side) the "System" tab. User sees a long delay / hourglass, or alternatively an error.

Symptom

CGI time-out or "Bad gateway" message inside IBM Cognos Administration


Cause

Microsoft Windows' TCP/IP network settings have several configurable limits/settings. The default settings may be too restrictive for some customers (especially in busy systems). Typically the following two settings are most important:

  • TcpTimedWaitDelay
Determines the time that must elapse before TCP can release a closed connection and reuse its resources. This interval between closure and release is known as the TIME_WAIT state or 2MSL state. During this time, the connection can be reopened at much less cost to the client and server than establishing a new connection.
  • MaxUserPort
Determines the highest port number TCP can assign when an application requests an available user port from the system. Typically, ephemeral ports (those used briefly) are allocated to port numbers 1024 through 5000.

Resolving the problem

Modify the Cognos application server's network settings to allow more freedom for TCP/IP communication. Specifically, for many customers the ideal settings are to alter the parameters to the following settings:

  • TcpTimedWaitDelay = 30
  • MaxUserPort = 65534

For more details, see Third Party (Microsoft) websites below

Related information

Microsoft TechNote for TcpTimeWaitDelay
Microsoft TechNote for MaxUserPort

Document information

More support for: Cognos Business Intelligence
Install and Config

Software version: 10.2, 10.2.1, 10.2.2

Operating system(s): AIX, Linux, Solaris, Windows

Software edition: Edition Independent

Reference #: 1496531

Modified date: 18 September 2017