IBM Support

CLSDST pass to a TELNET LU fails with sense codes 80030003 and 08570003.

Troubleshooting


Problem

TELNET LU has DEFAULTAPPL coded to automatically start a session to a Session Manager when the client connects. Once this session starts, the user selects an application from the Session Manager panel. The Session Manager issues a CLSDST pass to the new Application. When the new application initiates a session to the Telnet LU, the session fails, first with 80030003 and then with 08570003.

Cause

During the CLSDST pass the initial session between Telnet and the Menu Application ends. This causes the Telnet LU to close its ACB to VTAM which causes the 80030003 sense code. Then the CLSDST pass session to the new application fails with 08570003 because the ACB for the Telnet LU is now closed.

Resolving The Problem

LUSESSIONPEND should be coded in the Telnet profile for these LUs. This keeps the client connection active to Telnet and the ACB open during the CLSDST pass processing to the new application.

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Document Information

Modified date:
15 June 2018

UID

swg21496181