"Could not find any previously installed compliant product on the machine for installing this product" when installing IBM SPSS Statistics product or Fix Packs.

Technote (troubleshooting)


Problem(Abstract)

You are installing either the IBM SPSS Statistics program or a Statistics Fix Pack. During the installation process you are receiving the following message:

"Could not find any previously installed compliant product on the machine for installing this product".

The installation process then terminates and the program/fix pack is not installed.

Resolving the problem

IF you are experiencing this behaviour when installing the full IBM SPSS Statistics program, THEN you must first uninstall any instances of the SPSS Statistics Trial/Demo version (if present). It is also recommended that you rename the previous installation folder. For example, \Statistics\21 to \Statistics\21_old.

Once this has been done, you should be able to install the 'full' version of IBM SPSS Statistics normally.



IF you are experiencing this behaviour when installing IBM SPSS Statistics Fix Pack, THEN the cause is most likely due to a mis-match between the bit-version (i.e. 32-bit, 64-bit) of your Statistics program and that of the fix pack. Confirm whether you have SPSS Statistics 32-bit or 64-bit installed and download the fix pack with the corresponding bit-version.


Historical Number

86586

Rate this page:

(0 users)Average rating

Document information


More support for:

SPSS Statistics

Software version:

18.0, 19.0, 20.0, 21.0

Operating system(s):

Windows

Reference #:

1484890

Modified date:

2013-09-25

Translate my page

Machine Translation

Content navigation