Multiple comparisons not working in new nonparametric tests

Technote (troubleshooting)


Problem(Abstract)

I used the new Nonparametric Tests procedure (NPTESTS command) to run the Kruskal-Wallis and Friedman tests. I also requested multiple comparisons as part of these analyses. I do not see any output for the multiple comparisons in the Nonparametrics Tests output, but I do not see any warnings or error messages. Where can I find the multiple comparison output?

Resolving the problem

The default output format for NPTESTS is the Model Viewer. Note that you need to double-click the "Hypothesis Test Summary" table to open the Model Viewer to see further results. At the bottom border of the right panel of the Model Viewer, you will see a scroll bar titled "View". Use the scroll bar to choose "Pairwise Comparisons" and you will see the comparison tests and supporting graphics. There is a Print icon at the top border of the Model Viewer to print these results. Note that if the overall or omnibus test result is not significant, then the pairwise comparisons will not be performed.


You can find help on navigating viewers in Help->Contents. For a general tutorial on model viewers, Expand the "Core System" , then Scroll down to "Models" and expand that topic. You can find sections on "Interacting with a model" and "Working with the model viewer". For help on the viewer for NPTESTS, expand the "Statistics Base Option" topic and then the "Nonparametric Statistics" topic. Then open the topic "Model View (Nonparametric Statistics)". You can print all of the Views in the Model Viewer at once. To print all views, open the File Menu in a Model Viewer, then Properties, and then choose "Print all views".

You can choose to display all of the Nonparametric Tests Model Views on the Statistics Viewer, i.e., the Output window, i.e., the output window for SPSS Statistics, rather than the Model Viewer. In the Edit menu of Statistics, choose Options. In the Options dialog that opens , click the Output panel. In the Output dialog, go to the "Output Display" area and click the radio button beside "Pivot tables and charts". Click OK. Further Nonparametric Tests outputs will now be printed in syntax tables and charts in the Output viewer, rather than the Model Viewer.

Historical Number

84475

Rate this page:

(0 users)Average rating

Document information


More support for:

SPSS Statistics

Software version:

19.0, 20.0, 21.0

Operating system(s):

Windows

Reference #:

1483938

Modified date:

2015-02-15

Translate my page

Machine Translation

Content navigation