IBM Support

How do I fix 'Server Login' and 'Local computer' message on a host machine with a Windows operating system?

Troubleshooting


Problem

When starting IBM SPSS Statistics on a computer with a Windows operating system, a window displays with 'Server Login: Local computer'. The only response options are 'OK' and 'Cancel'. Selecting 'OK' results in no change. Selecting 'Cancel' results in the window closing but the IBM SPSS product does not work.

Cause

There are multiple causes for this behavior. The most common causes of the behavior are listed below.

Resolving The Problem

Platform compatibility
Please check the Product Compatibility Report of the product to confirm operating system compatibility.

Hardware resources

  1. Confirm that (a) the amount of Random Access Memory (RAM) and (b) speed of the central processing unit (CPU) meet or exceed the requirements for the installed version of Statistics.

    Information on hardware requirements for versions of the Statistics product can be found in the Product Compatibility Report for the product.
  2. Use the Task Manager 'Performance' tab to examine 'Free' RAM:
    • Press and HOLD the Control key.
    • Press and HOLD the Shift key.
    • Press and RELEASE Escape key. The Task Manager window will display.
    • Release the Control key.
    • Release the Shift key.
    • Select the 'Performance' tab.
    • In the 'Physical Memory' section of the window, 'Free' will be displayed.

The value value assigned to 'Free' RAM should exceed '1000' (MB). If it does not, reduce programs using RAM or add physical RAM to the host machine.

Permissions
When the host operating system has multiple user accounts and at least one of those accounts is a separate Administrator account, it is possible for a product installation to not receive the necessary privileges to access internal program resources. The result can be 'Server Login' behavior.

To address the 'Server Login' behavior resulting from incorrect permissions/privileges:
  • Uninstall Statistics.
  • Log into the end-user account.
  • Right-click the Statistics installer executable file and select the 'Run as administrator' option.
  • Proceed with installation in a manner consistent with your installation preferences.

Internet Security Software
Statistics software licensing uses Internet Protocol (IP) to communicate between subsystems of the program during the start-up process. To correct problems causes by internet security software see TechNote 1487006.

User Account Issues
The 'Server Login: Local computer' behavior can sometimes be caused by anomalies associated with a specific user account. To correct this, create a new (alternate) user profile with administrative privileges. Log into this account and start the Statistics program. If the behavior remits, it will be necessary to use the alternate user account to access the Statistics program.

Note: Transfer of the user account information (including files) from the previous user account to the new, alternate account would permit the alternate user account to function as the main account.

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Historical Number

77020

Document Information

Modified date:
16 April 2020

UID

swg21481547