Troubleshooting
Problem
Installing Omnibus 7.3.x on AIX system with a Tivoli Inventory scan, the install fails.
Symptom
From the Omnibus install log:
<errorMessages>
<errorMessage>[com.ibm.ac.si.ap.action.ActionException: ,
com.ibm.ac.common.hosts.CreationFailedException: : ]</errorMessage>
</errorMessages>
<actionErrorEvents>
<actionErrorEvent actionID="ConfigFile_1"
actionName="addFile">ACUCME1100E </actionErrorEvent>
</actionErrorEvents>
Cause
CIT directory used by Tivoli Inventory was not complete.
Diagnosing The Problem
In the DE_HOME/logs/de_trace.log, the wscanhw program fails -
Caused by: com.ibm.ac.si.ap.action.ExternalCommandActionException:
ACUOSI0050E External command action failed with return code 18.
Invocation string: [/usr/ibm/common/acsi/bin/wscanhw, -o,
/tmp/collector356.tmp, -c,
/usr/ibm/common/acsi/dat/config/scanconfig.xml]
at
com.ibm.ac.tp.basehost.ActionHandler.handlePhase(ActionHandler.java:233)
... 35 more
2011-03-24 13:09:54.915-05:00 1 ActionProcessorExceptionParms
ActionProcessorExceptionParms ews-pgh1-esmdr IP
rootException = com.ibm.ac.si.ap.action.ExternalCommandActionException:
ACUOSI0050E External command action failed with return code 18.
Invocation string: [/usr/ibm/common/acsi/bin/wscanhw, -o,
/tmp/collector356.tmp, -c,
/usr/ibm/common/acsi/dat/config/scanconfig.xml]
Resolving The Problem
Check the global CIT configuration file /etc/cit/cit.ini. The directory listed should have Tivoli Inventory binaries and be readable by the user installing DE. Move the file /etc/cit/cit.ini to /etc/cit/cit.ini.old. Uninstall Omnibus and run the installation again.
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Document Information
Modified date:
17 June 2018
UID
swg21474590