IBM Support


Cannot login into P8 AE Workplace automatically using the Workplace link on P8 Records Manager

Troubleshooting


Problem

Clicking on the Workplace link from within IBM ECM P8 Records Manager (RM) results in an error occurring and requiring the user to login to IBM ECM P8 Application Engine (AE) Workplace itself when it should be automatic.

Symptom

Log into RM and click on the Workplace link in the top right corner.

Instead of logging you into AE Workplace automatically you are requested for your login details. The following error appears when you click on details link for the AE Workplace login page that just opened:


Root Exception:                                                          
com.filenet.wcm.api.ConfigurationException: Cannot locate encryption key with keyId 397aac97 in                                                  
..\Programs\FileNet\Authentication\UTCryptoKeyFile.properties  

Cause

The Workplace URL link under Admin\Site Preferences\Refresh is not pointing to the AE Workplace you just logged into.

Resolving The Problem

  • Login to AE Workplace and goto Admin\Site Preferences\Refresh option
  • Change the Workplace URL link to point to the AE you just logged onto and click Refresh.
  • Logout of AE and restart your application server.
  • The Workplace link on your RM should now point to the correct AE and log you in automatically.

[{"Product":{"code":"SSNVVQ","label":"IBM Enterprise Records"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"3.5.1;3.7.0;4.5.0;4.5.1","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21473961