IBM Support

Framework Manager freezes then crashes with error: bmtui2 has stopped working

Troubleshooting


Problem

Framework Manager freezes (display goes cloudy) then crashes with an error

Symptom

bmtui2 has stopped working

Cause

Possible cause is one of the queries that are involved in the join in FM may have a self reference.

Diagnosing The Problem

To determine if one of the query items is a self reference, test each model query subject by right clicking on it and select test. If the error below shows, then it is possible that there is a self reference in one of the model query subjects:

Error:

BMTActionsHelper.cpp(488): CCLUnknownError:CCL_THROW:
BmtActionsHelper::DoAction

The application has encountered a non-recoverable error and is about to close. Please contact your System Administrator for assistance.

You can also double check this by double clicking the model query subject, and viewing the references.

Ex:

Model query subject named "DATE_TABLE" created with the intention of referencing a Datasource query subject called "DATE"

If you double click it, you may see items listed like "DATE_TABLE.date_key" instead of "DATE.date_key"

Resolving The Problem


Make sure there are no items that are self referencing.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Framework Manager","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1;10.1.1;10.2;10.2.1;10.2.2;8.4.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21473099