IBM Support

How to configure Red Hat Enterprise Linux 6 to run Rational ClearCase

Technote (FAQ)


Question

How do you configure a Red Hat Enterprise Linux 6 system to install and run IBM Rational ClearCase?

Cause

ClearCase requires some system packages which may not be installed on your Red Hat Enterprise Linux 6 system. These packages must be installed before you install and configure ClearCase.

Answer

Refer to technote 1459143: Unable to install Installation Manager on RHEL 6.0/6.1 (64-bit) if you need help installing the Installation Manager itself.

The set of packages that must be installed depends on the ClearCase version (7.1.2.x or 8.0.x.x) as well as on the system architecture (IA32, X86_64, PPC or S390).
The system installer is able to detect if a package is already installed on the system. If that is the case, it will not be reinstalled.

Refer to the ClearCase version and the hardware architecture of the Operating System you want to install for details.

1. Configuration Requirements for ClearCase 7.1.2.x, IA32
List of packages

  • "X Window System" (yum group)
  • "Desktop" (yum group)
  • compat-libstdc++-33
  • libXmu
  • libXp
  • ncurses-libs
  • openmotif22

To install the packages, open a terminal and type the following two command lines (each command in a single line):
# sudo yum -y groupinstall "X Window System" Desktop
# sudo yum -y install compat-libstdc++-33 libXmu libXp ncurses-libs openmotif22

2. Configuration Requirements for ClearCase 7.1.2.x, X86_64
List of packages
  • "X Window System" (yum group)
  • "Desktop" (yum group)
  • compat-libstdc++-33.i686
  • libXmu.i686
  • libXp.i686
  • ncurses-libs.i686
  • openmotif22.i686

To install the packages, open a terminal and type the following two command lines (each command in a single line):
# sudo yum -y groupinstall "X Window System" Desktop
# sudo yum -y install compat-libstdc++-33.i686 libXmu.i686 libXp.i686 ncurses-libs.i686 openmotif22.i686

3. Configuration Requirements for ClearCase 7.1.2.x, PPC
List of packages
  • "X Window System" (yum group)
  • "Desktop" (yum group)
  • compat-libstdc++-33.ppc
  • libXmu.ppc
  • libXp.ppc
  • ncurses-libs.ppc
  • openmotif22.ppc

To install the packages, open a terminal and type the following two command lines (each command in a single line):
# sudo yum -y groupinstall "X Window System" Desktop
# sudo yum -y install compat-libstdc++-33.ppc libXmu.ppc libXp.ppc ncurses-libs.ppc openmotif22.ppc

4. Configuration Requirements for ClearCase 7.1.2.x, S390x
List of packages
  • "X Window System" (yum group)
  • "Desktop" (yum group)
  • compat-libstdc++-33.s390
  • libXmu.s390
  • libXp.s390
  • ncurses-libs.s390
  • openmotif22.s390

To install the packages, open a terminal and type the following two command lines (each command in a single line):
# sudo yum -y groupinstall "X Window System" Desktop
# sudo yum -y install compat-libstdc++-33.s390 libXmu.s390 libXp.s390 ncurses-libs.s390 openmotif22.s390

5. Configuration Requirements for ClearCase 8.0.x, IA32
List of packages
  • "X Window System" (yum group)
  • "Desktop" (yum group)
  • libacl
  • libXmu
  • libXp
  • openmotif
  • ncurses-libs

To install the packages, open a terminal and type the following two command lines (each command in a single line):
# sudo yum -y groupinstall "X Window System" Desktop
# sudo yum -y install libacl libXmu libXp ncurses-libs openmotif

6. Configuration Requirements for ClearCase 8.0.x, X86_64
List of packages
  • "X Window System" (yum group)
  • "Desktop" (yum group)
  • libacl.i686
  • libXmu.i686
  • libXp.i686
  • openmotif.i686
  • ncurses-libs.i686
  • libstdc++.i686

To install the packages, open a terminal and type the following two command lines (each command in a single line):
# sudo yum -y groupinstall "X Window System" Desktop
# sudo yum -y install libacl.i686 libXmu.i686 libXp.i686 ncurses-libs.i686 openmotif.i686

7. Configuration Requirements for ClearCase 8.0.x, PPC
List of packages
  • "X Window System" (yum group)
  • "Desktop" (yum group)
  • libacl.ppc
  • libXmu.ppc
  • libXp.ppc
  • openmotif.ppc
  • ncurses-libs.ppc

To install the packages, open a terminal and type the following two command lines (each command in a single line):
# sudo yum -y groupinstall "X Window System" Desktop
# sudo yum -y install libacl.ppc libXmu.ppc libXp.ppc ncurses-libs.ppc openmotif.ppc

8. Configuration Requirements for ClearCase 8.0.x, S390x
List of packages
  • "X Window System" (yum group)
  • "Desktop" (yum group)
  • libacl.s390
  • libXmu.s390
  • libXp.s390
  • openmotif.s390
  • ncurses-libs.s390

To install the packages, open a terminal and type the following two command lines (each command in a single line):
# sudo yum -y groupinstall "X Window System" Desktop
# sudo yum -y install libacl.s390 libXmu.s390 libXp.s390 ncurses-libs.s390 openmotif.s390

Document information

More support for: Rational ClearCase
Operating System Configurations

Software version: 7.1.2, 8.0, 8.0.1

Operating system(s): Linux

Reference #: 1470870

Modified date: 22 March 2011


Translate this page: