Rational Functional Tester does not playback any action

Technote (troubleshooting)


Problem(Abstract)

Attempts to playback an IBM Rational Functional Tester script against Internet Explorer 8 or 9 result in zero playback actions.

Symptom

Start your HTML application in Internet Explorer under Windows 7.

    1. Record a script that inputs text in fields.

    2. Start to playback.

    3. See that nothing happens.

The following script does not playback anything.


*/
public void testMain(Object[] args)
{

// HTML Browser
// Document: developerWorks Registration:
//https://www.ibm.com/developerworks/dwwi/
// jsp/Register.jsp?&lang=en_US&
//appname=developerworks&d
//=http%3A%2F%2Fwww.ibm.com%2Fdeveloperworks%2F
///rfe%2F


text_fName().click(atPoint(169,7));
browser_htmlBrowser(document_developerWorksRegistr(),
DEFAULT_FLAGS).inputKeys("Johan{TAB}");
browser_htmlBrowser(document_developerWorksRegistr(),
DEFAULT_FLAGS).inputKeys("Huizinga{TAB}");
browser_htmlBrowser(document_developerWorksRegistr(),
DEFAULT_FLAGS).inputKeys("johan.huizinga.nl.ibm.com{TAB}");
browser_htmlBrowser(document_developerWorksRegistr(),
DEFAULT_FLAGS).inputKeys("Herfsttij der Midddeleeuwen{TAB}");
browser_htmlBrowser(document_developerWorksRegistr(),
DEFAULT_FLAGS).inputChars("Herfsttij der Middeleeuwen");
}
}


Cause

Unknown

Environment

Internet Explorer 8 or 9

Windows 7


Resolving the problem

  1. Change the user account control (UAC) settings.

    In the Control Panel click:

    User Accounts > Change User Account Control settings > Never notify

  2. Disable protected mode.

    Click Tools > Internet Options > Security and de-select Enable Protected Mode.

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational Functional Tester
Playback

Software version:

8.2.0.1, 8.2.0.2, 8.2.1, 8.2.1.1, 8.2.2, 8.2.2.1

Operating system(s):

Windows

Reference #:

1470694

Modified date:

2013-07-26

Translate my page

Machine Translation

Content navigation