Sametime System Console Installation Fails

Technote (troubleshooting)


Problem

The Sametime System Console (SSC) installation is failing.

Symptom

Error messages in the addnode.log file:
404 Not Found (for: /tmp/S105N94MSSCNode__1008123762695270997.car).

[2/22/11 15:02:20:666 EST] 00000000 AdminTool 3 Returning from auxiliary method issueMessage with return code: 113

[2/22/11 15:02:20:666 EST] 00000000 NodeFederatio > emitNotification Entry

[2/22/11 15:02:20:666 EST] 00000000 NodeFederatio 3 Notification type is websphere.addnode.failed


Error messages in the install.log file:

[exec] ADMU0014I: Adding node S105N94MSSCNode configuration to
cell: S105N94MSSCCell
[exec]
[exec]
[exec] ADMU0027E: An error occurred during federation 404 Not Found
(for:
[exec] /tmp/S105N94MSSCNode__1008123762695270997.car).;
rolling back to
[exec] original configuration.
[exec] ADMU0211I: Error details may be seen in the file:
[exec]
/QIBM/UserData/WebSphere/AppServer/V7/ND/profiles/STSCAppProfile/logs/ad
dNode.log
[exec] ADMU0026I: An error occurred during federation; rolling back
to original
[exec] configuration.
[exec] ADMU0113E: Program exiting with error:
[exec]
com.ibm.websphere.management.exception.AdminException:
[exec]
com.ibm.websphere.management.filetransfer.client.TransferFailedException
:
[exec] 404 Not Found (for:
/tmp/S105N94MSSCNode__1008123762695270997.car).,
[exec] resulting from:
[exec]
com.ibm.websphere.management.filetransfer.client.TransferFailedException
:Page 10 of 33
[exec] 404 Not Found (for:
/tmp/S105N94MSSCNode__1008123762695270997.car).
[exec] ADMU0211I: Error details may be seen in the file:
[exec]
/QIBM/UserData/WebSphere/AppServer/V7/ND/profiles/STSCAppProfile/logs/ad
dNode.log
[exec] *** Failed with exit status 255
[exec] Result: 20
Build sequence for target(s) `perform_error_exit' is
[perform_error_exit]
Complete build sequence is [perform_error_exit, setupResultsFile,
stii_core_init_default_props, setupLogFile, init_stii_core,
ssc_load_response_file, accept_licenses, ssc_v_required_props,
ssc_pre_init_validate, ssc_init_install_operation,
stwas_load_response_file, stwas_v_required_props,
eval_install_stii_framework, install_stii_framework,
stwas_v_was_installlocation, stwas_init_profile_names,
database_v_required_props, database_v_test_values, check_SSC_portlets,
validate_installAdditional, validate_QVFYOBJRST_value,
ssc_post_init_validate, ssc_validate, init_deployment_install_location,
copy_licenses, stwas_stage_install_files, stwas_install_WAS,
guarantee_QEJBSVR_temp_dir_authority, modify_setupCmdLine,
stwas_create_WAS_profiles, stwas_define_profile_port_props,
stwas_v_was_updateinstaller_install, stwas_install_was_updateinstaller,
stwas_stop_WAS_servers_security_enabled, stwas_update_WAS,
remove_stwas_staging_dir, copy_uninstall, ssc_stage_install_files,
start_SSC_install, create_properties1, copyFiles, create_properties2,
update_build, installce, installOffering, finish_SSC_install,
run_findSoapPortNoIM_ssc, run_postInstall_ssc,
post_install_configure_ssc, cleanup, print_was_server_summary,
printResults, perform_install, test_config_profiles,
test_SSC_schema_8.5, test_SSC_schema_8.5.1, determine_SSC_schema_level,
run_postInstall_ssc_update, stwas_start_nodeagent, updateOffering,
stwas_stop_WAS_servers_security_disabled,
update_SSC_schema_8.5_to_8.5.1, stwas_start_dmgr, update_SSC_schema,
installOffering_uninstall, no_op, install,
test_database_skip_validation, perform_update, stwas_start_appserver,
clear_passwords_from_response_file, ]
perform_error_exit:
[echo] INSTALL_FAIL
[echo] Failed creating WAS profiles.
[echo] Check log,
/QIBM/UserData/Lotus/stii/logs/install_STCONSOLE_20110222_1449.log, for
more details.
[echo] Printing the progress of the installer to this point:
[loadfile] loading
/QIBM/UserData/Lotus/stii/logs/install_STCONSOLE_20110222_1449_results.t
xt into property stii.results.content
[loadfile] loaded 567 characters
[echo]

Cause

The customer had WAS ND 7.0.0.13 installed in his IBM i (iSeries) environment and was attempting to use that version of WAS ND for the SSC install.

He did this by editing the following lines in the ssc.response.properties file:


# DO NOT CHANGE this settings unless instructed to do so by IBM Support.
#
### DO NOT CHANGE ###
stwas.was.installlocation=/QIBM/ProdData/WebSphere/Appserver/v7/SametimeWAS
stwas.was.profilelocation=/QIBM/UserData/WebSphere/Appserver/v7/SametimeWAS

Diagnosing the problem

The SSC installation files contain the WAS ND server version 7.0.0.3. This will automatically be installed as part of the SSC installation procedure automatically. Any other current versions of WAS ND will not be affected by this installation.

WAS ND 7.0.0.3 is absolutely required for the SSC installation to be be successful.


Resolving the problem

Use the SSC installation files as is, without any type of alteration.

The version of WAS ND can be updated after the successful installation of the SSC.


Related information

Installing The Console On IBM i


Rate this page:

(0 users)Average rating

Document information


More support for:

IBM Sametime
System Console

Software version:

8.5.1

Operating system(s):

IBM i, i5/OS

Software edition:

Standard

Reference #:

1470189

Modified date:

2013-02-15

Translate my page

Machine Translation

Content navigation