IBM Support

tdpoInit(): Error - Could not initialize InitOrcBlock()

Troubleshooting


Problem

Tivoli Data Protection for Oracle backups on a Windows platform fail with an initialization error and the RMAN log shows a failure to allocate the channel with an internal error, arguments [10019] krmxcr

Symptom

At the end of a backup, there is a problem to release the channel. Then any subsequent attempts to perform a backup fail since the orabst.dll is not unloaded due to the prior failure of the channel release. The subsequent backups will witness errors in the RMAN log similar to:


RMAN-03002: failure of backup command at 12/14/2010 21:46:08
RMAN-00600: internal error, arguments [10019] krmxcr [] [] []
RMAN-03009: failure of allocate command on ORA_SBT_TAPE_1 channel

The tdpoerror.log will show the error:
tdpoInit(): Error - Could not initialize InitOrcBlock()

This problem only has only been seen on Data Protection for Oracle 64-bit on Windows.

Cause

This failure on the release of the channel does not correctly free the orasbt.dll file that is used by the
Data Protection for Oracle and thus this library file is left is an unusable state. Any subsequent attempts to perform a Data Protection for Oracle backup will result in the InitOrcBlock error

Resolving The Problem

The initial problem is actually due to a failure for the RMAN channel to be released. This can occur even if there is only 1 channel allocated (it also happens when there are multiple channels allocated).
The backup processing at this point has completed and the data was successfully saved on the Tivoli Storage Manager Server, thus, there is no error message within the Data Protection logs to indicate any type of failure occurred. It is only within Oracle that the release of the channel encounters a failure.

The next backup after the channel release failure will witness the error:
tdpoInit(): Error - Could not initialize InitOrcBlock
This failure is expected as the orasbt.dll is not in a state to be loaded due to the prior failure of the channel release.

There are two options to address this backup failure.

1) A restart of Oracle or reboot of the Windows box will allow Data Protection for Oracle backups to again initialize and be performed successfully.

2) Adding the following parameter ORASBT_UNLOAD=1 within the parms option of the RMAN script will force the orasbt.dll to be unloaded, thus correcting this problem.

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Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21469677