IBM Support

DB2 expired license issue

Troubleshooting


Problem

A license expired notification is issued, upon starting instance user using db2start command.

Symptom

License expired notification
su - <instance user>

db2start

02/21/2011 02:58:05     0   0   SQL8000N  DB2START processing failed; a valid product license was not found. If you have licensed this product, ensure the license key is properly registered. You can register the license via the License Center or db2licm command line utility. The license key can be obtained from your licensed product CD.
SQL1032N  No start database manager command was issued. SQLSTATE=57019

Cause

Verify your DB2 license, using the following command:

<installation path>/adm/db2licm -l

Expiry date: "Expired"

Environment

DB2 V9.1, V9.5 and V9.7 on Linux/Unix environment

Resolving The Problem

Apply the permanent license, using the following command:

Note: For activating the permanent license, you are required to download the license key from DB2 customer site.


<installation path>/adm/db2licm -a db2<product>_u.lic

or

<installation path>/adm/db2licm -a db2<product>_c.lic

or

su - <instance user>

db2licm -a db2<product>_c.lic or db2licm -a db2<product>_u.lic

[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Install\/Migrate\/Upgrade - Licensing","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"9.7;9.5;9.1","Edition":"Advanced Enterprise Server;Enterprise Server;Express;Personal;Workgroup Server","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21468920