IBM Support

ABEND SYSTEM CODE=878 or USER COMPLETION CODE=4039 when WDI is processing a large input for EDI to XML Data Transformation.

Troubleshooting


Problem

When processing large inputs for Data Transformation, ABENDs may occur when virtual storage capacity is exceeded.

Symptom

Besides the abend codes above, the job log contains the following errors:

IEW4000I FETCH FOR MODULE CEEMENU3 FROM DDNAME -LNKLST- FAILED BECAUSE INSUFFICIENT STORAGE WAS AVAILABLE.

CSV031I LIBRARY ACCESS FAILED FOR MODULE CEEMENU3, RETURN CODE 24, REASON CODE 26080021, DDNAME *LNKLST*

Cause

Job is running out of virtual storage.

Diagnosing The Problem

The job log shows that this particular z/OS installation setting for virtual storage has been exceeded:

* STORAGE SECTION
USED PRIVATE AREA BELOW 16MB: 8000K ! ALLOWED PRIVATE AREA BELOW 16MB: 8000K      
USED PRIVATE AREA ABOVE 16MB:  399M ! ALLOWED PRIVATE AREA ABOVE 16MB: 400M  

This would confirm the short on storage condition. Even though REGION=0M specified on the EXEC statement, an installation limit of 400M is being reached.

Resolving The Problem

Increase the allowable REGION size for the user executing the job. The z/OS system programmer used "Region Size Control" of IEFUSI — Step Initiation Exit to limit a batch job's REGION size. The system programmer would need to increase this limit in order for the WDI job to obtain required storage above the 400M limit as set in this example.

[{"Product":{"code":"SSFKTZ","label":"WebSphere Data Interchange"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"WDI 3.3 z\/OS","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"3.3","Edition":"All Editions","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 August 2018

UID

swg21468880