IBM Support

Installation Manager attempts to connect to internet

Troubleshooting


Problem

You may notice that Installation Manager tries to connect to ibm.com, even when the web repositories are not specified and enabled. This article explains how to suppress the attempts to connect to ibm.com.

Cause

If Installation Manager is configured to connect to IBM's Passport Advantage site and also search for Installation Manager updates it will cause Installation Manager to automatically establish a connection with ibm.com. This will happen even if your list of repositories only contains local repositories.

Resolving The Problem

If the system does not have a connection to the Internet, or you prefer not to allow Installation Manager to attempt to connect to ibm.com, you can turn off those connection attempts. Follow the steps below to turn off each of the Installation Manager features which connect to external networks.

  1. Start Installation Manager.

    Note that you may skip or cancel the prompts for Passport Advantage credentials if you do not wish to connect to Passport Advantage when Installation Manager starts up.


  2. From the main Installation Manager window, open the File menu and choose the Preferences... option, as shown highlighted below:

    This screenshot highlights the "Preferences" option under the Installation manager File menu.


  3. Deselect repositories connecting to external networks.

    In order to prevent Installation Manager from connecting to any web repositories, review the list of repositories in the "Repositories" section of the Preferences. De-select any repositories which are not on the local filesystem. For example, de-select any repositories that have a location starting with "http://" or "https://". For more details, continue reading this step.

    First, be sure that you are looking at the Preferences window in installation manager. The screen will look similar to what is shown below.

    This screenshot shows the Repositories section of the Preferences menu.  Highlighted region 1 shows the navigation bar with Repositories selected, and highlighted region 2 shows the repository list.


    In the region labeled 1, be sure to select the "Repositories" view, as shown here:

    This is a larger view of highlighted region 1, showing the Repositories selection in the navigation list of the Preferences window.


    In the region labeled 2, review the list of repositories. If you do not want Installation manager to connect to ibm.com to retrieve repositories, then deselect any repository location which begins with "http://" or "https://". The screenshot below shows some items as they are deselected:

    This is a larger view of highlighted region 2, which shows several items starting with "http://" deselected from the repository list.


  4. Turn off the Search Service Repositories option.

    In order to prevent Installation Manager from connecting ibm.com to check for updates to your local repositories, open the "Repositories" section of the Preferences, and deselect the option at the bottom of the window which says, "Search service repositories during installation and updates". For more details, continue reading this step.

    First, be sure that you are looking at the Preferences window in installation manager. The screen will look similar to what is shown below.

    This is a screenshot showing the Repositoreis section of the Preferences window.  Highlighted region 1 shows the navigation bar with Repositories selected.  Highlighted section 2 shows the region of the window where you can find the Search checkbox.

    In the region labeled 1, be sure to select the "Repositories" view, as shown here:

    This is a larger view of region 1, showing Repositoreis selected in the navigation bar.

    In the region labeled 2, deselect the checkbox next to the option which says, "Search service repositories during installation and updates", as shown here:

    This is a larger view of region 2, showing the "Search service repositories during installation and updates" checkbox.


  5. Turn off the option to connect to Passport Advantage.

    Installation Manager is capable of connecting to IBM's Passport Advantage resources, which allows you to download certain repositories directly from IBM. This requires a connection to ibm.com.

    In order to prevent Installation Manager from connecting to Passport Advantage, open the "Passport Advantage" section of the Preferences window, and deselect the option which says, "Connect to Passport Advantage". For more details, continue reading this step.

    First, navigate to the "Passport Advantage" section of the Preferences window. This is highlighted in the region to the left in the screenshot below. Then, deselect the checkbox next to the option which reads, "Connect to Passport Advantage". This is highlighted in region to the right in the screenshot below.

    This is a screenshot showing the Passport Advantage section of the Preferences window.  The navigation bar is highlighted on the left, and the checkbox option is highlighted on the right.


  6. Turn off the option to search for Installation Manager updates.

    Installation Manager is capable of checking for newer versions of Installation Manager. This requires a connection to ibm.com.

    In order to prevent Installation Manager from connecting to ibm.com to search for updates to Installation Manager, open the "Updates" section of the Preferences window, and deselect the option which says, "Search for Installation Manager updates". For more details, continue reading this step.

    First, navigate to the "Updates" section of the Preferences window. This is highlighted in the region to the left in the screenshot below. Then, deselect the checkbox next to the option which reads, "Search for Installation Manager updates". This is highlighted in region to the right in the screenshot below.


    This is a screenshot showing the Updates section of the Preferences window.  The navigation bar is highlighted on the left, and the checkbox option is highlighted on the right.


  7. Press OK at the bottom of the Preferences window to save your selections.

    After these preferences are saved, Installation Manager will no longer connect to external sites.
If the problem still there after following the steps please contact IBM Support.

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"8.5.5;8.5;8.0;7.0","Edition":"Base;Express;Network Deployment","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21461757