Troubleshooting
Problem
Customer has a scheduled outage, during which they reboot all the servers. After the reboot, the TM1 data has disappeared. Why is all the TM1 cube data lost when the server is rebooted?
Symptom
TM1 (FAP) data is no longer in the cube. However:
- the dimensions are still available
- in the FAP client, the status is "ready" and "up-to-date".
Cause
By design, TM1 cubes run inside RAM memory (not stored on disk). This allows TM1 to act very fast.
- Therefore, when you a TM1 server is shutdown, the contents of the RAM memory are lost.
TIP: For more information on this topic, see the Proven Practice document "IBM Cognos TM1 Back-up and Recovery Guide".
Resolving The Problem
Fix
Write the TM1 data to disk, before restarting the TM1 server.
This is achieved by stop the TM1 cube Windows service well in advance (for example an hour?) of the complete Windows server reboot.
- This allows the TM1 server to write the data to file first (before rebooting the entire server).
Steps:
For full details (including other tips) see separate IBM Technote #1585881.
Workaround:
Perform an initial publish.
Steps:
1. Launch the FAP client
2. Click on the 'Data Mart' tab
3. Highlight the relevant data mart, and click on the 'stop' button
4. Click on the 'start' button
5. Click on the "Initial publish" button.
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg21461126