Troubleshooting
Problem
After downgrading from a DB2 Connect Server product to IBM Data Server Client or to DB2 Connect Personal Edition, a SQL1032N error may be received when connecting.
Symptom
Running a connect statement from a DB2 Connect Personal Edition client may receive the following error:
db2 connect to <dbname> user <userid> using <password>
SQL1032N No start database manager command was issued. SQLSTATE=57019
Cause
When downgrading from a DB2 Connect Server Product to a IBM Data Server Client or to a DB2 Connect Personal Edition, users will export the required configuration using the db2cfexp command before removing DB2 Connect Server:
'db2cfexp <filename> backup'
Once the Connect Server product has been removed and IBM Data Server Client of DB2 Connect Personal Edition is installed, an import of the configuration is done via the db2cfimp command:
'db2cfimp <fileame>'
Note: Not all DB2 Registry variables from a DB2 Connect Server product are valid for DB2 Connect client. The following DB2 Registry variable causes the SQL1032N error when connecting:
DB2CONNECT_IN_APP_PROCESS
- Operating system: All
- Default: YES, Values: YES or NO
- When you set this variable to NO, local DB2 Connect clients on a DB2 Enterprise Server Edition machine are forced to run within an agent. Some advantages of running within an agent are that local clients can be monitored and that they can use SYSPLEX support.
Diagnosing The Problem
1) Run the following command to view all the DB2 registry variables that are set:
db2set -all
2) Verify if the following setting is enabled:
[i] DB2CONNECT_IN_APP_PROCESS=NO
Resolving The Problem
Remove the DB2 registry variable. Run:
db2set DB2CONNECT_IN_APP_PROCESS=
db2 terminate
Related Information
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Document Information
Modified date:
16 June 2018
UID
swg21459726