IBM Support

Sessions display with a status of PCINIT

Troubleshooting


Problem

Many sessions to a single application are hanging with PCINIT status.

Cause

When VTAM builds or receives the CINIT, VTAM then calls the applications logon exit. At this point, the session status is put into a state of PCINIT. The application needs to acknowledge to VTAM that the Logon exit was driven by issuing an OPNDST or CLSDST macro. Until the application acknowledges the logon exit being driven, the session will hang in the PCINIT state.

Diagnosing The Problem

Display the LU with a D NET,ID=lu_name,E to display the session status.

Resolving The Problem

The application needs to be investigated to see why it is not responding to the logon exit being driven by VTAM.

[{"Product":{"code":"SSSN3L","label":"z\/OS Communications Server"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"All","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"1.10;1.11;1.12;1.13;2.1;2.2","Edition":"All Editions","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Document Information

Modified date:
15 June 2018

UID

swg21458236