Unable to access tm1p.xla/Perspectives: The specified module could not be found

Technote (troubleshooting)


Problem(Abstract)

Attempts to access the tm1p.xla via a mapped drive results in an error. May also occur on a locally installed instance of Perspectives.

Symptom

Run-time error '-2147024770 (8007007e)':

Automation error
The specified module could not be found.

Cause

The .dll/.ocx files are not registered.

Resolving the problem

Log in as an administrator and register the following files:

tm1prc.dll
tm1xl.ocx

To do that, go to a command prompt and cd to the TM1 installation directory bin folder and issue the following command:
Regsvr32.exe Tm1prc.dll Tm1xl.ocx

Then log into Perspectives the first time while still logged in as administrator.

If using Windows 2008 or Windows 7, be sure to right-click on the command prompt and choose Run as Administrator before attempting to register the files, or the following error will be issued:
RegSvr32
The module "tm1prc.dll" was loaded but the call
to DLLRegisterServer failed with error code 0x80004005.
For more information about this problem, search online using the error
code as a search term.

NOTE: According to our developers, TM1 is NOT designed to be run from a shared drive and even though you have been able to do it in the past by registering the tm1xl.ocx and tm1prc.dll as admin on the users' machines and then having the admin launch Perspectives for the first time, they can make no guarantee that this should/will work.

Making sure that you have the following Microsoft Visual C++ Redistributable patch (see link below) installed on the client machines (in addition to registering those files) may resolve the issue for you, but no guarantees are made. This patch would always need to correspond with the version of C++ that we use in development, which at this time is 2005. The Redistributable package and patch must be installed on all clients (whether accessed from a mapped drive or not) in versions 10.1 and 10.1.1.


Related information

Microsoft link

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Document information


More support for:

Cognos TM1
TM1

Software version:

9.4, 9.5, 9.5.1, 9.5.2, 9.4 MR1, 10.1.0, 10.1.1

Operating system(s):

Windows

Reference #:

1457282

Modified date:

2012-11-28

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