Troubleshooting
Problem
After the command 'set servername' is run on the Tivoli Storage Manager server, the client scheduler service will not be able to connect until the password is updated
Symptom
The scheduler service will stop running on the client machine and the following message will be displayed in the dsmerror.log:
ANS2050E TSM needs to prompt for the password but cannot prompt because the process is running in the background.
ANS1029E Communication with the TSM server is lost.
ANS1835E PASSWORDACCESS is GENERATE, but password needed for server 'SERVERNAME'.
Either the password is not stored locally, or it was changed at the server.
ANS1025E Session rejected: Authentication failure
Cause
The client scheduler keeps the Tivoli Storage Manager password stored in a registry key which is dependent on the server name such as:
HKLM\SOFTWARE\IBM\ADSM\CurrentVersion\BackupClient\Nodes\<NODENAME>\<SERVERNAME>\Password
Once the servername is changed, the client looks for the node's password key under the new location and does not find it.
Resolving The Problem
Either change the server name back to the original name using the 'set servername' command or use dsm, dsmc, or dsmcutil to manually set the password on all Windows clients that use the scheduler service.
Syntax on the dsmc and/or dsmcutil utility can be found by running it with the help flag, for example:
dsmcutil help
Product Synonym
TSM
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Document Information
Modified date:
17 June 2018
UID
swg21456196