IBM Support

Creating a new BaseCMActivity from a xclearcase client causes the xclearcase GUI to hang

Troubleshooting


Problem

If you create a new BaseCMActivity in a IBM Rational UCM ClearCase (CC)-ClearQuest (CQ) integration environment from xclearcas, the xclearcase GUI hangs.

Symptom

When you create a new activity for the new version during a check in/out, the xClearCase window hangs.

The BaseCMActivity can be correctly created by means of the CQ interface and a UCMBaseActivity previously created via the ClearQuest interface can be correctly set by the cleartool command from command line.

Cause

The xClearCase interface hangs because there is already an existing ClearQuest job running that prevents the ClearCase-ClearQuest integration interface from starting.

This can be reproduced by trying to create more than 1 activity at a time in different windows.

Environment

Linux CC-CQ integration

Diagnosing The Problem

Verify that a ClearQuest process is already running by doing the following:

  1. Open the Command Prompt (terminal session).

  2. Run ps -ef |grep clearquest

  3. Scroll through the output of previous command, and check that no ClearQuest process is already running.

Resolving The Problem

SOLUTION

If you find a ClearQuest job already running, do the following to prevent the hanging:

  1. Make a note of the Process ID.

  2. Run kill <process ID>.

  3. Create the UCMBaseActivity creation from the xClearCase interface.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"GUI: xclearcase","Platform":[{"code":"PF016","label":"Linux"}],"Version":"7.1.1;7.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21455092