Troubleshooting
Problem
If you create a new BaseCMActivity in a IBM Rational UCM ClearCase (CC)-ClearQuest (CQ) integration environment from xclearcas, the xclearcase GUI hangs.
Symptom
When you create a new activity for the new version during a check in/out, the xClearCase
window hangs.
The BaseCMActivity
can be correctly created by means of the CQ interface and a UCMBaseActivity
previously created via the ClearQuest interface can be correctly set by the cleartool
command from command line.
Cause
The xClearCase
interface hangs because there is already an existing ClearQuest job running that prevents the ClearCase-ClearQuest integration interface from starting.
This can be reproduced by trying to create more than 1 activity at a time in different windows.
Environment
Linux CC-CQ integration
Diagnosing The Problem
Verify that a ClearQuest process is already running by doing the following:
- Open the Command Prompt (terminal session).
- Run
ps -ef |grep clearquest
- Scroll through the output of previous command, and check that no ClearQuest process is already running.
Resolving The Problem
SOLUTION
If you find a ClearQuest job already running, do the following to prevent the hanging:
- Make a note of the Process ID.
- Run
kill <process ID>
.
- Create the
UCMBaseActivity
creation from thexClearCase
interface.
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Document Information
Modified date:
16 June 2018
UID
swg21455092