Troubleshooting
Problem
When running the installFixPack script provided in a special build or fixpack install image, the installation asks for the location of the db2_NLpack CD. If you do not have have this CD the installation cannot proceed.
Symptom
The installfixpack script is asking for the location of the db2_NLPACK CD like the message below:
Trying to install update: v9.7fp2_aix64_universal_fixpack.tar
Task #30 start
Description: Product Messages - Portuguese - Brazil
Estimated time 21 second(s)
Enter the location of the CD labeled "" or press enter to accept the
default path.
Volume label DB2_NLPACK_9_7_0_2_AIX
Type 'a' to abort the installation.
[/db2/universal/db2/aix/install/../../..]:
/db2/universal/
Cause
This is caused by the National Language (NL) pack being installed at the previous DB2 level.
Environment
UNIX and Linux only as there is no installfixpack on Windows systems.
Diagnosing The Problem
The errors will clearly state that the DB2_NLPACK needs to be installed.
Resolving The Problem
There are several things that can be done to resolve this issue.
- Install the NLPACK before the fix pack or Special Build. This will require a NLPACK fixpack install image or a special build for the NLPACK built on that same version as the first special build.
- De-install the NLPACK using de-install with the -F option and the feature you want to deinstall.
- Install the fix pack or special build in another directory and update the instance to use the new installation path.
Related Information
[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Install\/Migrate\/Upgrade - Instance","Platform":[{"code":"PF002","label":"AIX"}],"Version":"9.7;9.5","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21453753