Shared Memory from previous Notes/Domino run has been detected, this process will exit now

Technote (troubleshooting)


Problem

Using an 8.5 All Client (Notes client, Designer client and Administrator client) on Windows crashes when starting up the Designer client by itself or with any other client running.

Symptom

It is possible to receive the error "Shared Memory from previous Notes/Domino run has been detected, this process will exit now", and it is also possible to receive a dialog box stating that NSD is running, and the client will shut down.


Cause

The fatal thread of the NSD is as follows:

############################################################
### FATAL THREAD 1/14 [ NLNOTES: 1528: 15d0]
### FP=0x00134b44, PC=0x60001a19, SP=0x00134b38
### stkbase=00140000, total stksize=237568, used stksize=46280
### EAX=0x05ed3022, EBX=0x01ab1000, ECX=0x00000010, EDX=0x01abe13c
### ESI=0x01ab1000, EDI=0x05ed3022, CS=0x0000001b, SS=0x00000023
### DS=0x00000023, ES=0x00000023, FS=0x0000003b, GS=0x00000000 Flags=0x00010293
Exception code: c0000005 (ACCESS_VIOLATION)
############################################################
@[ 1] 0x60001a19 nnotes.Cmovmem@12+329 (1ab1040,5ed0160,fffe)
@[ 2] 0x60004374 nnotes.ODSReadMemory@16+116 (134d00,3,5ed0160,fffe)
@[ 3] 0x600ea9a2 nnotes.CSiteMapEntry::GetToolbarData+642 (1b04818,0,136d94,136d48)
@[ 4] 0x6378b192 nnotesws.CToolbarRequestHandler::WriteToolEntry+386 (46f6e58,1b04818,0,1b34e18)
@[ 5] 0x6378c44d nnotesws.CToolbarRequestHandler::WriteToolbarEntry+2237 (0,1b04818,1b34e18,10)
@[ 6] 0x6378ccf0 nnotesws.CToolbarRequestHandler::Execute+1904 (470eb28,1,1384b0,470ec58)
@[ 7] 0x61f92333 nxpm.CXmlRequestProcessor::ProcessRequestExt+819 (fd822c,470ec58,0,0)
@[ 8] 0x61f91550 nxpm.CXmlRequestProcessor::ProcessRequest+32 (fd822c,55,138db0,138dc0)
@[ 9] 0x63569105 nnotesws.ProcessWksMsgExt@32+10629 (57,10980000,0,f01041dd,0,0,0,0)
@[10] 0x63034223 nnotesws.CheckWksMQ@4+435 (0)
@[11] 0x63569dac nnotesws.ProcessDeskPollTimer+124 (63baabe0)
@[12] 0x63025324 nnotesws.CDeskSubprogram::SubMessageProc+660 (1ad8c18)
@[13] 0x63024b6d nnotesws.MainWndProc@16+7405 (1034c,113,1,0)
[14] 0x77d18734 USER32.GetDC+109 (63022e80,1034c,113,1)
[15] 0x77d18816 USER32.GetDC+335 (0,63022e80,1034c,113)
[16] 0x77d189cd USER32.GetWindowLongW+295 (139790,0,1397b4,630b8f0b)
[17] 0x77d18a10 USER32.DispatchMessageW+15 (139790,1,10320,63020000)
@[18] 0x630b8f0b nnotesws.NEMMainLoop@4+811 (4013a0)
@[19] 0x00401a2b NLNOTES.WinMain@16+1675 (630f72f0,0,16231d,0)
@[20] 0x00402641 NLNOTES.WinMainCRTStartup+389 (0,0,7ffd7000,805522fa)
[21] 0x7c817077 kernel32.RegisterWaitForInputIdle+73 (4024bc,0,78746341,20)

Resolving the problem

This issue has been reported to Quality Engineering under SPR ADC7MF38E, and is resolved in Notes 8.5.1.

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Document information


More support for:

IBM Notes

Software version:

8.5

Operating system(s):

Windows

Reference #:

1452714

Modified date:

2014-08-26

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