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WASX7017E Read timed out - when eventpurge.jacl script is run

Technote (troubleshooting)


Problem(Abstract)

If the eventpurge.jacl script is used to purge a large number of events, it can time out with the WASX7017E exception.

Symptom

The following error is written to the System.out log file:

WASX7017E: Exception received while running file "D:\IBM\WID612\runtimes\bi_v61\util\event\eventpurge.jacl"; exception information: com.ibm.websphere.management.exception.ConnectorException org.apache.soap.SOAPException: [SOAPException: faultCode=SOAP-ENV:Client; msg=Read timed out; targetException=java.net.SocketTimeoutException: Read timed out]


Cause

The default timeout value for the wsadmin SOAP client is 180 seconds. Unless you have increased the timeout value, the wsadmin scripting client that in running eventpurge.jacl will time out after 180 seconds, regardless of whether the event purge operation is still running in the background. When you are purging large numbers of events, it is likely that the operation will require more than 180 seconds.


Resolving the problem

Caution: If the eventpurge.jacl script times out with this error, do not immediately restart the script; it might still be executing, and a restart might interfere with the current job.


Resolve this problem by increasing the timeout value for the scripting client.

To do this, open the profileName/properties/soap.client.props file and adjust the value of the com.ibm.SOAP.requestTimeout property. You can assign a higher timeout value, or enter 0 (zero) to indicate the scripting client should never time out.

Document information

More support for: WebSphere Process Server
Common Event Infrastructure

Software version: 6.1, 6.1.2, 6.2, 7.0

Operating system(s): AIX, HP-UX, Linux, Solaris, Windows

Software edition: NA

Reference #: 1451446

Modified date: 10 November 2010


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