IBM Support

Deploying the RMI Registry (rmireg.war) in WebLogic 9.2, 10, 11 and 12

Question & Answer


Question

What is the procedure for deploying the RMIREG.WAR file to separate the RMI registry from any of the Maximo/TPAE application server members.

Cause

Not documented in installation and deployment guides

Answer

Deploying the RMI Registry (rmireg.war) File in WebLogic 9.2, 10, 11 and 12

RMI Stands for Remote Method Invocation. This is used for internal communications between Maximo/TPAE applications and external such as the Project Adapter, the report server, or any external application that uses Maximo/TPAE methods.

To understand how IBM has implemented Remote Method Invocation in this application, please review the document "Understanding the Maximo Implementation of Java Remote Method Invocation"

Maximo an RMI registry through a web application (rmireg.war). The tool used to build the rmireg.war file is {Maximo_home}/deployment/buildrmiregwar.cmd. This tool uses the settings in the {Maximo_home}/applications/maximo/properties/maximo.properties file to build a war (Web Archive) file with the necessary parameters to run in the Maximo environment.

To generate the necessary war file, first modify the maximo.properties file (Note: V7 stores properties in the database but for building rmireg.war the properties must be added to the maximo.properties file). When the properties have been properly modified, execute {Maximo_home}/deployment/buildrmiregwar.cmd to build the {Maximo_home}/deployment/default/rmireg.war file.

Definitions

RMI stands for “Remote Method Invocation.” Java developers created this standardized system for using Java objects in a separate memory area from the one calling the remote object. Separate memory areas can reside on the same physical system or on different systems connected by a network.

RMI uses JRMP (Java Remote Method Protocol) to travel over networks to the remote server being called.

For an in-depth tutorial on RMI from Oracle Sun, click on the "Oracle Sun Remote Method Invocation" link below. Note this link is to a non-IBM maintained website and IBM is not responsible for the content at this link.

Why Is This Important?

By default, when a Maximo/TPAE application starts, it checks for the existence of an RMI Registry on the port defined. If there is no registry, one will be created and the server will be registered. Subsequent JVM servers see the registry created by the initial server and register themselves in that registry. This causes the registry process to be attached to that initial instance of the application. If for any reason that instance is shut down or recycled, RMI communications will be lost for all servers in the cluster.

Any time there is more than one Maximo application deployed in a single environment or there is a vertically clustered environment for Maximo, the rmireg.war file should be deployed. This will prevent the inadvertent loss of RMI communications if application cluster members are shut down or recycled.

The attached document explains how to deploy the rmireg.war file using Oracle WebLogic 9.2 and later. Some visual elements of the WebLogic console interface captured in the illustrations in the document differ in WebLogic 10, 11 and 12. However, RMI Registry deployment procedure is identical for all versions of WebLogic 9.2 or later.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":"System Related","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.2.3;6.2.4;6.2.5;6.2.6;6.2.7;6.2.8;7.1;7.1.1;7.5;7.6","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSLKTY","label":"Maximo Asset Management for IT"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SS6HJK","label":"Tivoli Service Request Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSKTXT","label":"Tivoli Change and Configuration Management Database"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSWT9A","label":"IBM Control Desk"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21451075