How to replace an expired certificate using Tomcat with Rational Team Concert

Technote (FAQ)


Question

How do you replace an expired certificate when using Tomcat with IBM Rational Team Concert?

Cause

Receiving a certificate error when attempting to use IBM Rational Team Concert (RTC) with Tomcat.

Answer

Apply the following steps to replace the expired certificate:

  1. Access the keystore for Tomcat:
    1. Start ikeyman.exe which is located in one of the following directories:
      RTC 3.x and below:
      JazzInstallDir/server/win32/ibm-java2-i386-50/jre/bin/

      RTC 4.x and higher:
      \JazzTeamServer install directory> \server\jre\bin

    2. Click on Key Database File > Open

    3. Enter the following in the File Name field:
      C:\Program Files\IBM\JazzTeamServer\server\tomcat\ibm-team-ssl.keystore

    4. Click OK

  2. Create a Certificate:
    1. Select Personal Certificates to view the expired certificate ibm-team.

    2. Click View/Edit to display the contents.
      (Make note of this information. It will be used to create the new certificate.)

    3. Delete the ibm-team entry

    4. Select New Self Signed

    5. Enter ibm-team as the name

    6. Enter the information noted above in step 2.

  3. Install the Certificate:
    1. Open a browser to log on to Rational Team Concert

    2. Click Continue to the site

    3. Install the certificate

    4. Select Trusted Root Certification Authorities as the location to install

    5. Click OK

    6. Restart the browser

    Leverage the Jazz Community
    Jazz and Rational Team Concert have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki.
    Refer to technote 1319600 for details and links.

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational Team Concert
Team Server

Software version:

2.0, 2.0.0.1, 2.0.0.2, 3.0, 3.0.1, 3.0.1.1, 3.0.1.2, 3.0.1.3, 3.0.1.4, 3.0.1.5, 4.0, 4.0.0.1, 4.0.0.2, 4.0.1

Operating system(s):

AIX, Linux, Solaris, Windows

Reference #:

1450760

Modified date:

2013-03-01

Translate my page

Machine Translation

Content navigation