IBM Support

Clearlicense does not list all available licenses in the server

Troubleshooting


Problem

When you run IBM Rational ClearCase clearlicense, you do not see the correct amount of licenses.

Symptom

The clearlicense command displays how many licenses are available on the license server. No error message generated to claim that a license is invalid. Even after you restart the server and Rational ClearCase, nothing changes.

Cause

The registry does not recognise the update.

Resolving The Problem

Upgrade to Rational ClearCase release 7.1.2.


Start the Control Panel either as an administrator or from an admin-mode command prompt, if you cannot add licenses correctly with Rational ClearCase 7.1.2.



WORKAROUND

You have two options.


  1. Add the ClearCase licenses to the following registry key.

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Atria\ClearCase\CurrentVersion\LicenseKeys

  2. Disable UAC for Rational ClearCase. to run correctly.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Licensing","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF033","label":"Windows"}],"Version":"7.1.2.1;7.1.2;7.1.1.4;7.1.1.2;7.1.1.3;7.1.1.1;7.1.1;7.1.0.2;7.1.0.1;7.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
27 December 2019

UID

swg21450394