IBM Support

Adjusting the Maximum Queue Requests and Maximum Queue Wait runtime parameters for service operations in InfoSphere Information Services Director

Troubleshooting


Problem

When a deployed service is invoked, runtime errors can occur if the actual number of service requests exceeds the set maximum number of allowable queued requests and set maximum wait time that a particular operation is configured for. Depending on the underlying cause of the overflow errors, you can resolve these errors by tuning your system or by adjusting the runtime settings for future invocations of the particular service or application.

Symptom

You might see the following error messages, which include the current settings that are configured for these runtime parameters:

Maximum Queue Requests limit of <queue_requests_limit> exceeded.
Maximum Queue Wait limit of <queue_wait_limit> exceeded.

Cause

The actual number of service requests overflowed the maximum limits that are currently set in the operation runtime settings. When either of these settings are too low to accommodate the service requests, you might receive the error that the number of service requests has exceeded the limit.


This error can be due to many possible issues. For example, the client might be sending service requests too fast, the client might be sending in too many requests at one time, or the service request queue limits might be set too low.

Resolving The Problem

You can resolve these types of errors by updating the service operation runtime settings on the Operation Overview panel for the deployed application:

  • Reduce the number of requests that are coming into the system. This involves tuning your system.
  • Increase the queue size. This involves increasing the Maximum Queue Requests limit.
  • Increase the amount of time that a request can wait in the queue before timeout. This involves increasing the Maximum Queue Wait limit.

To choose the best solution, you must determine the underlying cause of the request overflow errors and then adjust your settings or tune your system accordingly.

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Document Information

Modified date:
16 June 2018

UID

swg21449932