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Create and startview errors: Cannot start dynamic view and Unable to create directory

Troubleshooting


Problem

This technote explains how to resolve errors, Unable to create directory, and, Cannot start dynamic view, that can occur when trying to create or start an IBM Rational ClearCase dynamic view.

Symptom


Attempting to start or create views on a remote server fails with "Unable to create directory"

Creating a view may result in an error such as the following:

---
Error creating view -- '<view>'                    
                                                 
Created view.                                      
Host-local path: <path>                            
Global path: <path>                                
Unable to create directory "<view>": -1781401617  

---

Starting a view may result in:

---
Cannot start dynamic view <view>                
Unable to create directory "<view>": -204147855

---

Creating and starting local views on the clients succeed, as does creating or starting directly on the remote view-server.

Cause


The client or view-server installation is corrupted. The symptoms would typically be seen immediately after applying a Fix Pack of iFix.

Environment


Diagnosing The Problem

A cleartool -verall showing a mismatch between the MVFS and the other modules is a clear indication of corruption.

Example:
---
C:\Documents and Settings\user1>cleartool -verall

ClearCase version 7.0.1 (Thu May 17 09:19:01 2007)
ClearCase version 7.0.1_iFix01 (Wed Sep 19 11:15:35 2007)
ClearCase version 7.0.1.1 (Wed Nov 28 17:43:24 2007)
ClearCase version 7.0.1.1_iFix01 (Tue Feb 12 10:48:57 2008)
ClearCase version 7.0.1.1_iFix02 (Wed May 14 23:53:33 2008)
ClearCase version 7.0.1.2 (Fri Jul 18 12:43:48 2008)
ClearCase version 7.0.1.3 (Wed Nov 19 12:29:56 EST 2008)
ClearCase version 7.0.1.4 (Mon Mar 02 14:30:47 EST 2009)
ClearCase version 7.0.1.5 (Tue Jun 02 22:42:30 EDT 2009) (7.0.1.05.00_2009B.FCS)
ClearCase version 7.0.1.6 (Thu Jul 23 16:54:25 EDT 2009) (7.0.1.06.00_2009C.FCS)
ClearCase version 7.0.1.7 (Tue Oct 13 14:33:32 EDT 2009) (7.0.1.07.00_2009D.FCS)
ClearCase version 7.0.1.7-iFix01 (Fri Dec 11 13:37:12 EST 2009) (7.0.1.07.01_2009D.1.FCS)
ClearCase version 7.0.1.8 (Mon Mar 01 23:34:37 EST 2010) (7.0.1.08.00_2010A.D100301)
@(#) MVFS version 7.0.1.1 (Wed Nov 28 00:57:20 2007)
cleartool                         7.0.1.8 (Tue Mar  2 02:36:06 2010)
libatriaadm                       7.0.1.8 (Thu Feb 25 21:58:29 2010)
libatriaccfs                      7.0.1.8 (Thu Feb 25 22:16:42 2010)
libatriaclient_meters             7.0.1.8 (Thu Feb 25 22:27:21 2010)
libatriacm                        7.0.1.8 (Thu Feb 25 22:05:31 2010)
libatriacmd                       7.0.1.8 (Thu Feb 25 22:28:57 2010)
libatriacmdsyn                    7.0.1.8 (Thu Feb 25 22:30:00 2010)
libatriacredmap                   7.0.1.8 (Thu Feb 25 22:00:16 2010)
libatriadbrpc                     7.0.1.8 (Thu Feb 25 22:04:28 2010)
libatriaks                        7.0.1.8 (Thu Feb 25 21:55:35 2010)
libatriamntrpc                    7.0.1.8 (Thu Feb 25 22:31:08 2010)
libatriamsadm                     7.0.1.8 (Thu Feb 25 21:53:44 2010)
libatriamvfs                      7.0.1.8 (Thu Feb 25 22:33:07 2010)
libatriasplit                     7.0.1.8 (Thu Feb 25 22:17:13 2010)
libatriasum                       7.0.1.8 (Sat Feb 27 04:43:52 2010)
libatriasumcmd                    7.0.1.8 (Thu Feb 25 22:25:04 2010)
libatriatbs                       7.0.1.8 (Thu Feb 25 21:57:25 2010)
libatriatool                      7.0.1.8 (Thu Feb 25 22:16:58 2010)
libatriaview                      7.0.1.8 (Thu Feb 25 22:15:53 2010)
libatriavob                       7.0.1.8 (Fri Feb 26 12:59:05 2010)
libatriaxdr                       7.0.1.8 (Thu Feb 25 21:59:44 2010)
db_server                         7.0.1.8 (Fri Feb 26 03:54:52 2010)
VOB database schema version: 54

---

In the above output you can see that the MVFS is running at 7.0.1.1 and everything else at 7.0.1.8.

This should be checked on both client and view server.

Resolving The Problem

An uninstall and re-install on the machine will be necessary to resolve the issue.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"MVFS","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1.2;7.1.1.4;7.1.1.3;7.1.1.2;7.1.1.1;7.1.1;7.1.0.2;7.1.0.1;7.1;7.0.1.9;7.0.1.8;7.0.1.7;7.0.1.5;7.0.1.6;7.0.1.4;7.0.1.3;7.0.1.2;7.0.1.11;7.0.1.10;7.0.1.1;7.0.1;7.0.0.9;7.0.0.8;7.0.0.7;7.0.0.6;7.0.0.5;7.0.0.4;7.0.0.3;7.0.0.2;7.0;7.0.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21449500