Troubleshooting
Problem
The IBM WebSphere Application Server services for Rational RequisitePro, Rational ClearCase, and Rational ClearQuest fail to start with an error following a server crash or reboot.
Symptom
This problem affects these Rational services and their applicable WebSphere Application Server profiles:
- ClearCase Remote Client (CCRC) and ClearQuest Web
IBM WebSphere Application Server V6.1 - cmprofile
- ClearQuest Full-Text Search
IBM WebSphere Application Server V6.1 - cqsearchprofile
- Report Server for ClearQuest
IBM WebSphere Application Server V6.1 - reportalprofile
- RequisitePro RequisiteWeb
IBM WebSphere Application Server V6.1 - RWP ReqWeb Servlet
You can experience this behavior with these services after a crash or reboot:
- Services are not running as expected after the reboot of the server.
- Services will not start when manually requested. An error like this will occur:
Windows could not start the 'IBM WebSphere Application Server V6.1 - RWP ReqWeb Servlet' on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service specific error code 134218764.
- The affected WebSphere Application Server profile might not indicate any timestamp changes or log updates that are normally expected during a startup failure. For example, the startServer.log file within this directory of the profile:
<install directory>\IBM\RationalSDLC\common\CM\profiles\<profile name>\logs\server1
... does not show an update indicating the Windows service associated with the profile tried to start.
Cause
This occurs if a stale pid file is left behind in the logs directory. This can cause a conflict with the service startup process.
Environment
This problem is observed on Microsoft Windows platforms.
Diagnosing The Problem
Attempt to start the service. Verify if the startServer.log file gets updated. If it is not updated, proceed to the resolution below.
Resolving The Problem
- Locate the server1.pid file in the this directory for the affected profile:
<install directory>\IBM\RationalSDLC\common\CM\profiles\<profile name>\logs\server1
- Remove the server1.pid file. Alternatively, you can rename the file to server1.pid.old for backup purposes.
- Attempt to start the service again. Upon successful startup, the server1.pid file should be regenerated.
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Document Information
Modified date:
16 June 2018
UID
swg21447764