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Error 134218764 occurs when starting WebSphere services for Rational products after crash or reboot

Troubleshooting


Problem

The IBM WebSphere Application Server services for Rational RequisitePro, Rational ClearCase, and Rational ClearQuest fail to start with an error following a server crash or reboot.

Symptom

This problem affects these Rational services and their applicable WebSphere Application Server profiles:

  • ClearCase Remote Client (CCRC) and ClearQuest Web
  • IBM WebSphere Application Server V6.1 - cmprofile


  • ClearQuest Full-Text Search
  • IBM WebSphere Application Server V6.1 - cqsearchprofile


  • Report Server for ClearQuest
  • IBM WebSphere Application Server V6.1 - reportalprofile


  • RequisitePro RequisiteWeb
  • IBM WebSphere Application Server V6.1 - RWP ReqWeb Servlet


You can experience this behavior with these services after a crash or reboot:

  1. Services are not running as expected after the reboot of the server.

  2. Services will not start when manually requested. An error like this will occur:

    Windows could not start the 'IBM WebSphere Application Server V6.1 - RWP ReqWeb Servlet' on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service specific error code 134218764.

  3. The affected WebSphere Application Server profile might not indicate any timestamp changes or log updates that are normally expected during a startup failure. For example, the startServer.log file within this directory of the profile:

    <install directory>\IBM\RationalSDLC\common\CM\profiles\<profile name>\logs\server1

    ... does not show an update indicating the Windows service associated with the profile tried to start.

Cause

This occurs if a stale pid file is left behind in the logs directory. This can cause a conflict with the service startup process.

Environment

This problem is observed on Microsoft Windows platforms.

Diagnosing The Problem

Attempt to start the service. Verify if the startServer.log file gets updated. If it is not updated, proceed to the resolution below.

Resolving The Problem

  1. Locate the server1.pid file in the this directory for the affected profile:

    <install directory>\IBM\RationalSDLC\common\CM\profiles\<profile name>\logs\server1

  2. Remove the server1.pid file. Alternatively, you can rename the file to server1.pid.old for backup purposes.

  3. Attempt to start the service again. Upon successful startup, the server1.pid file should be regenerated.

[{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"RequisiteWeb","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1;7.1.1;7.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"CM Server","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ClearCase Remote Client","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"CM Server","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Full-Text Search","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Reporting","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Web Server (7.1)","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21447764