IBM Support

LIC1416N with -110 when installing a new DB2 license

Troubleshooting


Problem

Installing a new DB2 license file fails with error message LIC1416N and a return code of -110.

Symptom

The following db2licm command demonstrates this error message:

    $ db2licm -a db2ese_c.lic

    LIC1416N The license could not be added to the nodelock file automatically. The return code is "-110".

Cause

The DB2 nodelock file could be corrupted, preventing the operation from succeeding.

Resolving The Problem

Create a backup copy of the DB2 nodelock file and then create a new one from scratch maintaining the same operating system permissions and ownership as the original file.


  1. Rename the <db2 installation directory>/license/nodelock file to nodelock.bak
    ... where <db2 installation directory> is the location where DB2 was installed (eg, /opt/IBM/db2/v9.7)
  2. Create a new nodelock file in this directory by issuing the command: touch nodelock
  3. Using root make sure the permissions and ownership of the new nodelock file match the permissions and ownership of the original file using chmod and chown.
  4. Try installing the license again by issuing the db2licm -a command again.

[{"Product":{"code":"SSEPGG","label":"Db2 for Linux, UNIX and Windows"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Install\/Migrate\/Upgrade - Licensing","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"9.7;9.5;9.1;10.1;10.5","Edition":"Enterprise Server;Express;Personal;Workgroup Server","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21447189