IBM Support

Failure in upgrading WebSphere Process Server test environment of WebSphere Integration Developer to V7.0.0.3

Troubleshooting


Problem

During the installation of WebSphere Integration Developer V7.0.0.3 , when upgrading the WebSphere Process Server test environment to V7.0.0.3, you may experience an installation failure

Symptom

The following errors might occur:

1) IBM Installation Manager shows a validation error during the prerequisites checking; This message indicates that one or more interim fixes are not synchronized. (7.0.0.7-WS-WAS-WinX32-IFPK98944 and 7.0.0.x-SDKPM00452).

Cause

All the interim fixes that have been installed using the Update Installer (UPDI) must be removed with the Update Installer before starting V7.0.0 Fix Pack 3 activities. Two interim fixes were installed silently during the V7.0.0.0 install: SDKPM00452.pak and 7.0.0.7-WS-WAS-<platform><arch>-IFPK98944.pak. These will need to be removed, if you have not already done so.

The instruction on how to upgrade WebSphere Process Server test environment have been published here : http://www.ibm.com/support/docview.wss?uid=swg27019234.

Please follow this instructions to successfully upgrade WebSphere Process Server test environment to V7.0.0.3.

Resolving The Problem

The following failures may occur:

1. IBM Installation Manager stops at the prerequisites checking , indicating that the upgrade can not be accomplished because of two existing files (7.0.0.7-WS-WAS-WinX32-IFPK98944 and 7.0.0.x-SDKPM00452).







2. IBM Installation Manager stops when running the update with following error messages:






In order to work around this issue :

1. Any interim fixes that have been installed using the WebSphere Update Installer must be removed with the Update Installer before starting V7.0.0 Fix Pack 3 activities. Two interim fixes were installed silently during the V7.0.0.0 install: SDKPM00452.pak and 7.0.0.7-WS-WAS-<platform><arch>-IFPK98944.pak.

These will need to be removed, if you have not already done so.



First download and install the IBM Update Installer V7.0.0.11 for WebSphere Software from following source page http://www.ibm.com/support/docview.wss?uid=swg24020448.

Next, start the Update Installer and uninstall the following two packages and any additional fixes installed through the Update Installer:


2. Add repositories to the IBM Installation Manager preferences. Click File -> Preferences. Under Repositories select one of the following:
If the machine on which you have installed WebSphere Enterprise Service Bus, WebSphere Process Server, or WebSphere Process Server Client has internet access, ensure the following repository is present: http://public.dhe.ibm.com/software/websphere/repositories/ (A) and for the online upgrade the Service repository from the IBM Installation Manager (B).



If the system does not have internet access, download the repositories locally and add them to your Installation Manager repository list.

[{"Product":{"code":"SSQQFK","label":"WebSphere Integration Developer"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Upgrade","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.0.0.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSQQFK","label":"WebSphere Integration Developer"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Upgrade","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.0.0.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21446037