Upgrading Rational ClearQuest from 7.1.0.x to 7.1.1.x, 7.1.2.x or 8.0.x.x fails on AIX systems

Technote (troubleshooting)


During the upgrade of IBM Rational ClearQuest on the IBM AIX Platform, several errors can prevent the operation from completing. The product might not work correctly after the upgrade failure, and subsequent attempts to install the product fail.


Upgrade of Rational ClearQuest version 7.1.0.x to 7.1.1.x, 7.1.2.x or 8.0.0.x fails with several errors. These errors are related to the execution of the chmod and wsadmin.sh commands.

This example shows the types of messages that you might see:

Example error messages:

Update failed.
Error during "pre-install configure" phase:
Error executing "chmod()" operation (status=-1).
See agent output log for more information: /var/ibm/InstallationManager/logs/native/20100809_0459.log
Error executing "/opt/ibm/RationalSDLC/common/CM/profiles/cqsearchprofile/bin/wsadmin.sh" operation (status=105).
See agent output log for more information: /var/ibm/InstallationManager/logs/native/20100809_0459a.log

Additional errors like those in the example might be present in the installation logs.


Issues with the Rational ClearQuest 7.1 installation program prevent the upgrade from completing correctly. This problem is currently being investigated by the product development team.

Resolving the problem

After the upgrade operation has failed, manually remove IBM Rational ClearQuest 7.1 from your system. Refer to the document: Uninstalling ClearQuest 7.1 on Linux or UNIX for more information.

After ClearQuest has been removed, use IBM Installation Manager to install Rational ClearQuest 7.1.1.x, 7.1.2.x or 8.0.x.x directly to avoid the issues seen during the previous upgrade attempt,

Document information

More support for:

Rational ClearQuest

Software version:

7.1.1,,,,,,,,,, 7.1.2,,,,,,,,,,,,,,,,,,,, 8.0,,,,,,,,,,,,,,,,, 8.0.1,,,,,,,,,

Operating system(s):


Reference #:


Modified date:


Translate my page

Content navigation