ACO5424E Could not connect to SQL server

Technote (troubleshooting)


Problem(Abstract)

There are several possible reasons why the ACO5424E error may be observed when using MS SQL Server 2005

Cause

The connection to the SQL server methodology changed with SQL Server 2005 and some administration is required to ensure remote connections are allowed

Diagnosing the problem

Using Microsoft's supplied utility, sqlcmd.exe, an administrator can verify the name of the SQL server, the proper connection string, and the accessibility of remote connections. The following command can be executed to ensure that the SQL server name is being identified correctly:
sqlcmd -S <servername>
or
sqlcmd -S <servername\instance_name>

Such as:
sqlcmd -S LORENZO\LAMASSQL

Alternately, it is possible to specify a named pipes connection with the following syntax:
sqlcmd.exe -S np:\\ \pipe\MSSQL$ \SQL\query

For other uses of the sqlcmd utility and complete syntax guide, refer to Microsoft document:
http://msdn2.microsoft.com/en-us/library/ms162773.aspx

Resolving the problem

If the following is seen:

ACO5424E Could not connect to SQL server; SQL server returned:

Failed to connect to server <local-computername>\<instancename>
An error has occurred while establishing a connection to the
server. When connecting to SQL Server 2005, this failure may be
caused by the fact that under the default settings SQL Server
does not allow remote connections. (provider: SQL Network
Interfaces, error: 26 - Error Locating Server/Instance
Specified) (HRESULT :0x80131501)

Check the following:
1) If upgrading from a previous version of MS SQL Server, the sqldmo.dll may be the incorrect version or may not exist. Newer version of these files can be downloaded from the Microsoft site:
http://www.microsoft.com/downloads/details.aspx?familyid=D09C1D60-A13C-4479-9B91-9E8B9D835CDC&displaylang=en

2) That remote connections are allowed:
http://support.microsoft.com/kb/914277

3) Tivoli Storage Manager APAR IC54894 may be responsible for the failure to connect. Since the default connection mode was changed in the Data Protection SQL 5.5 release, it may be necessary to force the named pipes syntax (or apply the 5.5.1 or greater release of the Data Protection client):
http://www-1.ibm.com/support/docview.wss?uid=swg1IC54894

4) That the SQL Server Browser is running. SQL Server Browser should be running to have connections to named instances via named pipes. At start time, SQL Browser starts and claims UDP port 1434. SQL Browser reads the registry, identifies all SQL Server instances on the computer and notes which ports and named pipes they use.

When SQL Server 2005 clients (including the Data Protection for SQL) request SQL Server resources, the client network library sends a UDP message to the server using port 1434. SQL Browser responds with the TCP/IP port or named pipe of the requested instance. The network library on the client application then completes the connection by sending a request to the server using the port or named pipe of the desired instance.

5) Setting up an alias within MS SQL Server 2005 works around some issues with oddly named instances or unusual pipe names. From the SQL Server Configuration Manager, select SQL Native Client Configuration, then Aliases. Right click in the pane on the right and select "new alias" and then set the following parameters:

Alias Name: <aliasname>
Protocol: np
Server: <local-computername>
Pipe Name: \\.\pipe\MSSQL$ \sql\query

The following command now should work (forcing a connection using named pipes)
tdpsqlc q sql /sqlserver=np:<aliasname>


Product Alias/Synonym

TSM DP

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Document information


More support for:

Tivoli Storage Manager for Databases
Data Protection for MS SQL

Software version:

5.5

Operating system(s):

Windows, Windows Server

Reference #:

1445251

Modified date:

2013-07-23

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