IBM Support

Server fails to start as a service.

Troubleshooting


Problem

The Tivoli Storage Manager server may fail to run as Windows service.

Symptom

Server service fails to start and/or stay running. However when you start the server in the foreground using the User Account that installed the server and instance, the server will start without error.

Cause

The user ID that is being used to run the server service does not have sufficient access to the DB2 database to start the Tivoli Storage Manager server.

Diagnosing The Problem

Open a DB2 command window by selecting Start > All Programs > IBM DB2 > Command Line Tools > Command Window - Administrator
Then run, run the following commands:

set db2instance=server1
db2 connect to TSMDB1
db2 "select grantee,securityadmauth from syscat.dbauth"


The output returns the user ID that is authorized to the database. Verify that the Windows account you want to use to run the service is listed.

Resolving The Problem

If the account is not listed, you can perform the following steps to add it.

1. Log on with the user ID that created the Tivoli Storage Manager server instance.
2. Open a DB2 command window by selecting Start > All Programs > IBM DB2 > Command Line Tools > Command Window - Administrator
3. Then run the following commands:

set db2instance=server1
db2 connect to TSMDB1
db2 grant dbadm with dataaccess with accessctrl on database to user XXX
db2 grant secadm on database to user XXX


In the two grant commands, XXX is the user ID from which the Tivoli Storage Manager server service is to be run.

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Product Synonym

TSM IBM Spectrum Protect

Document Information

Modified date:
17 June 2018

UID

swg21445245