Technote (troubleshooting)
Problem(Abstract)
Upon accessing SLMAdmin or SLMReport console the DYKSD2002E error is displayed.
Cause
Problems creating one or both of sdc and dmt datasources.
Diagnosing the problem
Check the DYK logs for SLMServer, SLMReport, and SLMAdmin for errors associated with datasource creation for sdc and/or dmt. Also check the WAS SystemOut.log for datasource creation errors
Resolving the problem
Reconfigure one or both datasources depending on which one(s) is/are creating the problem by issuing dsutil:
dsutil dmt url=jdbc:db2:dyk_dm
driver=COM.ibm.db2.jdbc.app.DB2Driver
userid=<db2userid> password=<db2password>
dsutil sdc url=jdbc:db2:dyk_cat
driver=COM.ibm.db2.jdbc.app.DB2Driver
userid=<db2userid> password=<db2password>
You can then check the configuration of each one by issuing:
dsutil dmt
dsutil sdc.
Please note that you should also check that the user id and password are correct by connecting to dyk_dm and dyk_cat from the command line.
After the changes, restart both the SLMServer and WAS. The SLMServer should always be started before the WAS server to ensure correct datasource information is available to the SLMAdmin and SLMReport apps.
Rate this page:
Copyright and trademark information
IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.