Feature and patches required when extending an existing Eclipse 3.6 IDE with version 8.0 of Rational Software Delivery Platform products

Technote (FAQ)


Question

Are instructions available on how to install version 8.0 of Rational Software Delivery Platform products into an existing Eclipse 3.6 integrated development environment (IDE)?

Answer

To successfully install version 8.0 of a Rational Software Delivery Platform product on top of Eclipse 3.6 (sometimes referred to as "extending Eclipse"), follow the instructions corresponding to your product available at this IBM developerWorks resource:
https://www.ibm.com/developerworks/community/wikis/home?lang=en#!/wiki/Rational+Installation+Wiki/page/Install+into+an+Existing+Eclipse+instance

Instructions are available for the following products:

  • Rational Software Architect (RSA), Version 8.x
  • Rational Software Architect for WebSphere Software, Version 8.x
  • Rational Application Developer (RAD) for WebSphere Software, Version 8.x
  • Rational Application Developer Standard Edition for WebSphere Software, Version 8.x
  • Rational Software Architect RealTime Edition (RSA RT), Version 8.x
  • Rational Business Developer (RBD), Version 8.x

Additional References

(Note that Rational Software Architect v8.0.x and Rational Application Developer v8.0.x support 3.6.x or later 3.x Eclipse and not 4.x Eclipse.)


Cross reference information
Segment Product Component Platform Version Edition
Software Development Rational Software Architect for WebSphere Software Installation Linux, Windows 8.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.4.1, 8.0.4.2, 8.5, 8.5.1, 8.5.5
Software Development Rational Application Developer for WebSphere Software Installation Linux, Windows 8.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.4.1, 8.0.4.2, 8.0.4.3, 8.5, 8.5.1, 8.5.5
Software Development Rational Application Developer Standard Edition for WebSphere Software Not Applicable Windows, Linux 8.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.4.1, 8.0.4.2, 8.0.4.3
Software Development Rational Software Architect RealTime Edition Installation Linux, Solaris, Windows 8.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.5, 8.5.1
Software Development Rational Business Developer Eclipse 8.0.1, 8.0.1.1, 8.0.1.2, 8.0.1.3, 8.0.1.4, 8.0.1.5, 8.5, 8.5.1, 8.5.1.1

Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

Rational Software Architect
Installation

Software version:

8.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.4.1, 8.0.4.2, 8.5, 8.5.1, 8.5.5

Operating system(s):

Linux, Windows

Reference #:

1443053

Modified date:

2013-12-05

Translate my page

Machine Translation

Content navigation