IBM Support

ALARMPROGRAM is not backing up logical logs or calling the script

Troubleshooting


Problem

With the ONCONFIG configuration parameter ALARMPROGRAM set to alarmprogram.sh or alarmprogram.bat or log_full.sh or log_full.bat you do not see logical logs or other ALARMPROGRAM related actions taking place.

Symptom

  • Logical logs are not automatically backed up by ALARMPROGRAM, but no errors from onbar or ontape.
  • ALARMPROGRAM related actions are not taking place, but you see no errors

Cause

  • Incorrect permissions on one of these files:

    alarmprogram.sh
    alarmprogram.bat
    log_full.sh
    log_full.bat
    your custom file

  • The variable BACKUP_CMD is not set correctly in alarmprogram.[sh|bat].
  • If using ontape, LTAPEDEV is set to a tape drive or file instead of a directory.
  • If using ontape, LTAPEDEV is set to a directory with incorrect permissions, owner, or group.
  • ALARMPROGRAM is set incorrectly in the ONCONFIG file.
  • The oninit permissions are incorrect. They should look like this:

    -rwsr-sr--  1 root informix 37835249 Nov 17 14:51 /informix/bin/oninit

Environment


Diagnosing The Problem

  • Run ls -l or dir on the ALARMPROGRAM value to ensure it is set correctly and does exist.
  • Run your logical log backup command manually to make sure it will successfully backup the logs. The command would typically be one of these:

    onbar -b -l
    ontape -a -d *** Informix versions 11.x and higher
  • ls -l on the LTAPEDEV value to see if it is a directory
  • ls -l on the LTAPEDEV value to see if it has owner/group informix and 660 permissions
  • Run the alarmprogram manually from the command line to make sure it works. You will have to have 2 or more logical logs that are not backed up for this test. If you only have 1 logical log not backed up then run this command to force the logical log to move to the next log:

    onmode -l

    Run onstat -l to make sure their are now 2 or more logical logs not backed up. Run the alarmprogram manually like this, let it run for 10 to 15 seconds then Ctrl-C:

    /full/path/to/informixdir/etc/alarmprogram.sh 2 23

    Now check the online.log to see if the logical log was backed up or if the alarmprogram.sh gave an error while running.

Resolving The Problem


Any changes made to ALARMPROGRAM or the file it is set to require a restart of Informix for that change to take affect.

  • These files must have read and execute permissions:

    alarmprogram.sh
    alarmprogram.bat
    log_full.sh
    log_full.bat
    your custom file

  • If using alarmprogram.[sh|bat], then make sure the variable BACKUP_CMD is set correctly in the file. It is typically set to one of these values:

    onbar -b -l
    ontape -a -d *** Informix versions 11.x and higher

  • Create a directory with owner/group informix and 660 permissions. Set LTAPEDEV to that directory.

  • Change the LTAPEDEV directory to have owner/group informix and 660 permissions.

  • Set the ALARMPROGRAM configuration parameter correctly. Make sure the all parts of the path and file name are spelled correctly and use the same case ( UPPER or lower case ) as the actual path and file on disk.

  • Correct the oninit permissions:

    chmod 6754 oninit
    chown root:informix oninit

  • Include and set all environment variables that your storage manager would typically require for an onbar backup from the command line.

  • IC69182 MISSING ALARMS POSSIBLE IF THREAD HAS MIGRATED VPS WHILE ISSUING AN ALARM

    You must have an ibm.com account to view this APAR ( click here to sign up ). The fix will be included in 11.50.xC9 and 11.70.xC2 ( download here once available ).

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Document Information

Modified date:
16 June 2018

UID

swg21441711