Details for WebSphere MQ V701 installation on IBM i 7.1

Technote (troubleshooting)


Problem(Abstract)

The prerequisites for WebSphere MQ V701 installation on IBM i 7.1

Resolving the problem

IBM i 7.1 requires object conversion of WebSphere MQ programs and service programs (since these were built using older versions of the operating system).

You must do object conversion before applying any WebSphere MQ PTFs. To convert an existing WebSphere MQ installation use the IBM i operating system command, STROBJCVN LIB(QMQM).

Alternatively, conversion can be requested when installing WebSphere MQ by specifying FRCOBJCVN(*YES *RQD) on the RSTLICPGM command.

For example:
RSTLICPGM LICPGM(5724H72) DEV(&DEV) OUTPUT(*PRINT) FRCOBJCVN(*YES)

To prevent slow performance resulting from automatic conversion upon first use of an unconverted object, you must also convert objects after applying any WebSphere MQ PTFs. As stated above, use command STROBJCVN LIB(QMQM).

Please note that product identifiers referenced in the System Requirements document are different with IBM i 7.1, (now 5770xxx instead of 5722xxx)

Also, please note that starting with IBM i 5.4, the Crypto Access Provider (5722-AC3) product is part of the base IBM i operating system (5770SS1)


Rate this page:

(0 users)Average rating

Add comments

Document information


More support for:

WebSphere MQ
Install / Migration

Software version:

7.0.1

Operating system(s):

i5/OS, iSeries

Reference #:

1440667

Modified date:

2012-09-11

Translate my page

Machine Translation

Content navigation