IBM Support

Using the "Profile Port Checker" to find potential port conflicts with WebSphere Application Server servers

Troubleshooting


Problem

When duplicate ports are set on 2 or more servers, on the same physical host, then the application server might fail to start or will start with exceptions. Manually searching each server configuration for the list of ports used by each server, and searching for duplicates, is time consuming.

Cause

Duplicate ports set for multiple application servers on the same host machine.

Resolving The Problem

  1. Place the profilePortChecker.jar and the run_profilePortChecker.[sh|bat] utility in the following directory:

  2. install_root\bin

  3. Run the run_portfilePortChecker.[sh|bat] script from the command line.

    Usage:

  4. run_profilePortChecker.sh [-l] [[-html || [-csv]]
    or run_profilePortChecker.sh [-c] [-html]
    or run_profilePortChecker.sh [-cd  "/profileName/config"] [-d output_path] [-html]
    or run_profilePortChecker.sh [-f  "/path/collector.jar"] [-d output_path] [-html]

    Examples:

    ./run_profilePortChecker.sh -f "/tmp/collector.jar" -html
    run_profilePortChecker.bat -f "C:\tmp\collector.jar" -html

    Parameters:

    • Local system:

    • -lList all the ports for each server for each profile found on current System
      -c Same as "-l", plus report any duplicate port settings amongst the servers
      -cdSame as "-c" but starts scan at the "*/profile/<profileName>/config" dir
      -cdAlso works for ISALite collections. Starts scan at the "*/<profileName>" dir
    • Jar/zip file:

    • -f "path to collector.jar", same as "-c" but searches the jar rather than system
    • Output:

    • -dDirectory path to the location where the output file to be written
      -csvOutput data in comma separated value format. (CSV)
      -htmlOutput data in html format

      Default is to use text format in a log file

  5. The profilePortChecker utility will scan the serverindex.xml files, either on your host server, in the Collector tool, or in the IBM Support Assistant Lite (ISA Lite) script collection jar. It will then produce a .log or .html report with the list of all server ports. If you are using -c or -f, the report will also include any potential port conflicts found on the "local" server.

  6. Use the results of this report to make any port setting changes required to prevent port conflicts. Changes can be made through the administrative console or through wsadmin commands. See the Information center for your version for additional information on setting server ports.

Example results file:

profilePortChecker.html

Download profilePortChecker tool:

profilePortChecker.zipprofilePortChecker.zip
(updated 10/11/2013)

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"System Management\/Repository","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"8.5.5;8.5;8.0;7.0","Edition":"Base;Developer;Express;Network Deployment","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21440402