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Unable to log in to TM1: Failed to create client credential for integrated login

Troubleshooting


Problem

Attempting to login to TM1Web and you receive a dialog box entitled 'Message from Webpage'

Symptom

Integrated Login Failed...Please try again...154 TM1APIDOTNET Exception: - Failed to create client credential for integrated login.

Cause

Incorrect authentication protocol being used or group issue.

Resolving The Problem

Edit the tm1s.cfg file in the data directory of your server instance and change the following parameter from Kerberos to NTLM:

SecurityPackageName=Kerberos is the default protocol.


Changing this parameter to NTLM will only work if the TM1 web server is on the same machine as the TM1 server. If on separate machines, you will be forced to use Kerberos. Please see below link to the Operations guide for detailed steps to setting up integrated login. Pay particular attention to giving Authenticated Users permissions to the TM1Web files, to running the Negotiate,NTLM command and granting delegation rights for the web server.

If you happen to be using Kerberos with CAM authentication, refer to technote 1351398 (link below).

This error may also occur if a user is set up in TM1 but has not yet been assigned to a group. Have the admin log in and verify that the user is in a group.

Related Information

[{"Product":{"code":"SS9RXT","label":"Cognos TM1"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"TM1","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5.1;9.5;9.4 MR1;9.4;9.1;9.0","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21437878