IBM Support

Error -131, no free disk space during onbar backup with heavy activity

Troubleshooting


Problem

Error 131, no free disk space during onbar backup with heavy activity. Onbar will not complete the back up and give the following error code. 2013-04-01 02:23:31 4156272 3241528 Unable to get storage space backup data from the database server: ISAM error: no free disk space. -131 ISAM error: no free disk space.

Symptom

Not enough contiguous free disk space is available to complete the current operation. For C-ISAM programs, if transaction logging is in use, roll back the current transaction. Make some disk space available, and run the program again. For SQL products, roll back the current transaction, if possible. Contact the system administrator about acquiring more disk space for databases.

With heavy activity during level zero archive, onbar will not be able to complete the archive, and you will receive the following error:

Archive failed - ISAM error: no free disk space.

Onbar will consume temp dbspace. It apparently sorts every before image page into the temp table which created for each dbspaces.

Onbar will free the temp table after the dbspace has been backed up, but with heavy activity on the instance, if there are many dbspaces with big chunks, there will not be enough temp dbspaces for completing the archive.

The problem of an archive aborting with the 'Error 131, no free disk space' error, occurs as a result of Online running out of disk space while writing pages to a temp table. A temp table for each dbspace is created when the archive process is started. These temp tables contains pages that have been modified since the archive started. After an individual dbspace is backed up, the corresponding temp table will then be backed up and dropped. This same process is repeated for each dbspace

This procedure is important to the warm restore feature. The benefit of this feature is that it allows the ability to restore a single dbspace when the system is in online mode.

For example, if a drive fails which contains 1 dbspace, you can replace the drive and perform a restore to that dbspace only, without having to restore the whole Online system To take advantage of this feature you must use transaction logging.

In addition, a critical dbspace cannot be restored with a warm restore. e.g.(root dbspace or a dbspace which contains the logical or physical log)

Cause

With heavy activity during level zero archive, onbar will not be able to complete the archive, and receive the following error:

Archive failed - 131 ISAM error: no free disk space.

Environment


Resolving The Problem

Workarounds that will reduce the chance of hitting this condition:

  • Increase size of temp dbspace . This will give the maximum allowable space to the archive process. For example increase temp dbspace by 2gig.
  • Perform archives at off peak times. This will cut down on the amount of temporary space used.
  • Add one or more additional temporary dbspaces. This will help the archive indirectly by giving additional temporary space to other online process. If this is done, and the temporary dbspaces are not all the same size, then set:

DBSPACETEMP = to the larger spaces.

For example, if temp1 and temp2= 2 gig, and temp3 and temp4 =1 gig, then set:

DBSPACETEMP = temp1:temp2, otherwise, the archive may create a temp table in one of the
smaller temp dbspaces

  • Use /tmp by setting PSORT_DBTEMP to a UNIX file system. If the platform supports large file systems, you can set:

    PSORT_DBTEMP = to a UNIX file system for the onbar session only. This will not affect the other users.
  • Implement incremental archives. Level 0 archives the whole online system, while level's 1 and 2 will archive pages that have been modified since the last archive. This will reduce the archiving time, which will help in scheduling for off peak time

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Document Information

Modified date:
16 June 2018

UID

swg21433140